Error Message if going to settings


#1

If I change to the settings, I see very often an error message like:

err@/lib/dojo/dojo.js?1519373847:8:39326
_1b4@/lib/dojo/dojo.js?1519373847:8:45285
@/js/PrefFilterTree.js?1519377343803:24:9
_ce@/lib/dojo/dojo.js?1519373847:8:11945
_37@/lib/dojo/dojo.js?1519373847:8:13569
_81/<@/lib/dojo/dojo.js?1519373847:8:13833
_38@/lib/dojo/dojo.js?1519373847:8:13659
_81@/lib/dojo/dojo.js?1519373847:8:13758
_f6@/lib/dojo/dojo.js?1519373847:8:15537
_10b@/lib/dojo/dojo.js?1519373847:8:18464

After a reload, it work without problem. I found no more information in the error-protocol of TT-RSS about that. I used Firefox 58.02 but tried also Vivaldi 14

At the moment I don’t know what does that mean. Are there something wrong with my Webbrowser, my Webserver, my TT-RSS installation, or ???

tt-rss version (including git commit id):
17.12 (not sure if I did correct, but I get bcdbfa7c675832704095fd65157bcc421becbf95)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Debian 9, PHP7, MySQL

Additional informtion:
I uploaded the files with ftp and used the files from git clone https://tt-rss.org/git/tt-rss.git tt-rss => I used also git push to get the latest files.

best regards, Andyt


#2

this has been reported before and it could be some kind of problem / race condition related to dojo module loader and network / browser caches / could be anything else really.

it only happened to me maybe two times over several years so i never managed to investigate anything.

tldr: i dunno.


#3

Hello fox,

Thank you for your answer.

At the moment I get it always during my first change to settings. A reload (with settings url) work without troubles. After that, I’m able to change back to normal view and return back to settings without troubles. After some time, it return.

The same problem occur if I use “Firefox Integration” for RSS-Feed. It send the feed to TT-RSS without troubles, but if I want to change any additional settings (like category) and want to change to the settings, I see the same problem. In the most cases it work without troubles if I will wait some more seconds after using “Firefox Integration”.

You tell me something about dojo module and browser cache. I use Firefox 58.0.2 and have pinned TT-RSS, so it is always there. In the most time, I don’t close TT-RSS - even for hibernation. So it look like that this increase the probability of such rare condition?

Is there any information how do reduce the risk of such failure? By the way, dojo module is something from Webbrowser or TT-RSS? It seems to me last one…

edit: oh, I forgot a question: that error isn’t really a problem - I mean no damage to TT-RSS settings/database or similar?

best regards, Andyt


#4

module loader is dojo, like i said it’s hard to say what could be the cause but it’s unlikely that this involves some kind of damage to your installation because ctrl-r makes everything work properly.

you can try opening F12 dev console next time this happens and see if there’s anything worth reporting in there (including possibly failed network transfers), other than that i don’t know what to suggest. :man_shrugging:


#5

Thanks for your response. The problem don’t occur if I reload the Tab with TT-RSS before I switch to settings.

However, I will look to F12 dev console next time and give response if there will some new information.

regards, Andyt


#6

Hello

I have some new information. The number of error messages is reduced if I reload the website before going to the settings. It is similar if I will add new RSS-Feeds with Firefox integration and going there to the settings.

However, sometimes there is still an error message like today

Error: declare fox.PrefFilterTree: unknown base class. Did you use dojo.require to pull it in?
Stack trace:
err@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:39326
_1b4@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:45285
@https://webrss.blackseals.net/js/PrefFilterTree.js?1520343830559:24:9
_ce@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:11945
_37@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13569
_81/<@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13833
_38@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13659
_81@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13758
_f6@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:15537
_10b@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:18464
prefs.php:102:110
Error: declare fox.PrefFilterTree: unknown base class. Did you use dojo.require to pull it in?
dojo.js:8:39326
{“error”:{“code”:6,“message”:“Nicht autorisierte Abfrage.”}}
prefs.php:102:348
Error: declare fox.PrefLabelTree: unknown base class. Did you use dojo.require to pull it in?
Stack trace:
err@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:39326
_1b4@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:45285
@https://webrss.blackseals.net/js/PrefLabelTree.js?1520343830559:3:9
_ce@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:11945
_37@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13569
_16/<@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:7929
_38@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:13659
_16@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:7914
req@https://webrss.blackseals.net/lib/dojo/dojo.js?1519373847:8:555
@https://webrss.blackseals.net/js/PrefLabelTree.js?1520343830559:1:1
prefs.php:102:110
Error: declare fox.PrefLabelTree: unknown base class. Did you use dojo.require to pull it in?
dojo.js:8:39326
{“error”:{“code”:6,“message”:“Nicht autorisierte Abfrage.”}}

There is one interessing part in the original error message: “Nicht autorisierte Abfrage”. The translation will be “Unauthorized query”. Is there something missing from the authentication? For example I mean reading failure from cookie or is that wrong? In the error message is also an unknown base class - don’t know what that mean?

regards, Andyt


#7

unauthorized is most likely tt-rss backend replying to tt-rss frontend trying to report the actual error

other than that, interesting


#8

If I unterstand correctly… it mean, the whole error message wasn’t helpful - or just that point with “unauthorized”?

By the way - such error message didn’t occur since that time. Maybe it is gone?


#9

this is the arguably helpful part although i don’t know why would the loader fail like that

the unauthorized part is unlikely to be related to this specifically (it’s probably because tt-rss couldn’t initialize -> there was no csrf code -> error submission failed)

anyway, i haven’t got any new ideas on this. it’s up to people who have this problem to investigate further, i think.


#10

I have the same problem. It breaks for me with these 2 commits:

commit 4fa64e8446563a89f04badfdfecc8a57750c083d
Author: Andrew Dolgov 
Date:   Wed Mar 21 14:02:06 2018 +0300

    filter dialog: remove placeholder

commit e794e434da1e3029162a5dd2b999b83f1342cab2
Author: Andrew Dolgov 
Date:   Wed Mar 21 13:38:36 2018 +0300

    filter dialog: add tooltip re: filter syntax

Meaning, if I roll back from 4fa64e8446563a89f04badfdfecc8a57750c083d to e794e434da1e3029162a5dd2b999b83f1342cab2, then it’s still broken.

If I roll back to this commit:

commit e35a46733fe48d2cd1e64bd7020531b0587f1bbe
Author: Andrew Dolgov 
Date:   Fri Mar 16 21:34:01 2018 +0300

    hlClicked: do not set headline selected when ctrl-clicking

Then everything works fine.

Platform:
OS: CentOS 7.4
PHP: 5.4.16
Web: Apache 2.4.6


#11

i find it hard to believe that those are directly related


#12

I upgraded today to commit:

54727f9534f8b17b57d87577ed1ec0e8be8be0f3

from a very, very old release and I encountered this same issue:

Unhandled exception

Error: declare fox.PrefLabelTree: unknown base class. Did you use dojo.require to pull it in?

Stack trace:

err@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:39326
_1b4@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:45285
@https://news.my.domain/js/PrefLabelTree.js?1534944381975:3:9
_ce@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:11945
_37@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:13569
_16/<@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:7929
_38@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:13659
_16@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:7914
req@https://news.my.domain/lib/dojo/dojo.js?1534921542:8:555
@https://news.my.domain/js/PrefLabelTree.js?1534944381975:1:1

My workaround at present is to acknowledge the error and [CTL]+[SHIFT]+[R] (Firefox, NixOS) to completely reload the page and preferences will then reload OK and work as expected.

Happy to do any requested further digging to help resolve this.


#13

does this happen each and every time you go into preferences if you don’t do ctrl-shift-r? clearing the cache manually should probably help.


#14

Thanks fox.

This occurs each and every time I enter preferences, regardless of whether I had refreshed or not.

Occasionally I’ll need multiple refreshes (I’ve just been testing it repeatedly - otherwise I rarely use preferences).

I’ve cleared browser cache and cookies which have made no difference.

This appears, in my limited testing, to be a TT-RSS + Firefox (61.0.1 (AMD64-bit)) issue, as I installed Chromium and was completely unable to replicate it there.

I’m also using the dark theme, in case that makes any difference, although I tested this under the default theme too, with the same results.


#15

oh. i don’t even have firefox installed anymore. maybe its a browser addon? this had happened before.

have you tried with a clean browser profile / incognito?


#16

Good thoughts, I hadn’t tested those.

  • In a clean profile, with no addons loaded: Same error
  • In a clean profile, with no addons loaded, in private browser mode: Same error

Dead ends unfortunately. I thought we had a winner there for a moment. :smiley:


#17

the fact that ctrl-shift-r clears it means its very likely related to a (stale) cached something. not necessarily in browser, could be proxy or something.

not sure what to tell you tbh. if that is some kind of mozilla / dojo incompatibility there’s not much i can do. :frowning:

open F12 console before going to preferences and see if there’s anything interesting (i.e. errors) in there anywhere. not just output log, other tabs too.

also, check if there’s stale files in tt-rss/cache/js. delete everything in there.

e: i’ve installed firefox (clean profile, default settings) and predictably it doesn’t happen to me.


#18

My usage look really similar to yours. I have still the same problem. I tried Vivaldi (which use Chromium), but I found only in one situation the same problem, but I don’t use Vivaldi so much as Firefox.

I disabled plugins in TT-RSS and I found less error messages, but they still occur.


#19

does this error show up if you open prefs.php in browser? if so you can try opening prefs.php?debug=1 (with F12 console open) so that JS minification is disabled and maybe we can get better context to the error.

e: going by stack trace its CheckBoxTree that doesn’t load for some reason, the file for it is lib/CheckBoxTree.js, maybe there’s unusual going on with it in the console?


#20

I will try it later. At the moment I see no error messages, because I did a reload of the website and successful enter to settings. At the moment I’m able to switch between settings and feeds without interrupt. It take some time in my Firefox until the error message return.