Tiny Tiny RSS: Community

Combined (unexpanded) mode has to go


#35

LOL. Meh, if you can make it work, cool. If not, I’ve still used tt-rss for YEARS so it was high time. :+1:


#37

yeah, this already works on my private branch
just wait a bit, the suffering will be over soon

there’s btw some minor behavior changes: i’ve removed the long standing annoyance i had with how article active state clashed with selected state, so those are now separate; to make sure hotkeys like “u” work as expected active article is considered a honorary member of the selection

my current refactoring efforts in that area involve a metric assload of commented-out horrible code


#38

Ok thanks!

/20 chars


#39

first stage of the great headlines refactoring is here:

report all issues itt, i guess


#40

I just updated via git.

Left clicking on the title marks the article read. Earlier it opened the article’s url.
Now I have to “ctrl+left click” if I want to visit the original website.

Not sure if it is an intended behaviuor


#41

combined or normal mode?

e: combined, right, gonna fix this in the next changeset

pull


#42

It’s working now.
Thanks


#43

alright guys

report all issues, etc

it’s really sad how i can’t ever remove anything


#44

We love you @fox!!! :crazy_face:


#45

I was afraid this was going to ruin my experience. I made a note of the last commit before all this went down. Then I did a git pull, clicked Reload in my browser, and prepared myself for the worst.

And absolutely nothing changed.

So I have a feeling I wasn’t using this feature and I won’t miss it.

:smiley:


#46

either that or you managed to update after it was re-added back :slight_smile:


#47

How do I enable it? In prefs I only see “Combined feed display”, but no option to disable expanded view. Am I missing something?


#48

f c toggles between expanded/unexpanded


#49

Working now, thanks for bringing this back!


#50

I am running 78780c9c08cde4b7e7ee44efa29fa5c19a918040
Now clicking on link inside post does nothing, except marking the article read.
Ctrl+click does not work.

At the moment I can only right click on the link, copy the url and pasting it in a different tab.

I am using Chrome 70.0.3538.110

Tried to refresh, log out and back in, but it does not change behaviour.


#51

yeah it’s a small bug, should be fixed in trunk now


#52

Yep. It’s back to normal now.
Thanks


#53

At present on on commit b572295 . Using in chromium-browser, incognito mode and other browsers as well, now the following issue…

Previously, right-clicking on an article headline, then clicking ‘Open Original Article’ in the context menu would open the article in a new browser tab and mark the clicked article ‘read’.

This isn’t happening anymore (the marking ‘read’ part). Usually configured in Preferences as ‘Combined feed display’, but now regardless of config, articles are not being mark ‘read’ when right-clicking, etc. as described above.

Is this intended?
.


Impending doom part 2: Objects
#54

i’ll take a look when i’m done with current stuff, thanks for reporting

e: fixed on staging branch


#55

Now, when selecting a new feed or category the first article is automatically selected and thus marked-as-read.
Can this be fixed ?
Thanks.