Tiny Tiny RSS: Community

404 Not Found when trying to add a valid rss feed


#1

Hello,

I’m trying to add this rss feed => http://www.brusselstimes.com/rss-feed?format=feed&type=rss
But I always have this error message => Couldn’t download the specified URL: HTTP/1.1 404 Not Found

The URL is valid and I tried an other RSS reader just to be sure, and it’s working fine.

Am I missing something ? Can you check the issue ?

Thank you.


#2

I’m going to guess they’re filtering by user-agent. Check out some of the solutions in this thread and see if it resolves the issue (post back here to confirm):

https://discourse.tt-rss.org/t/change-on-tumblr-rss-feeds-not-working/1158/129

You can also SSH to the server itself and try with curl to see the results (curl lets you change the user agent easily to experiment if that’s the issue).


#3

I took the exact CURL request from my browser

curl “http://www.brusselstimes.com/rss-feed?format=feed&type=rss” -H “User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0” -H “Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8” -H “Accept-Language: en-US,en;q=0.5” --compressed -H “Connection: keep-alive” -H “Upgrade-Insecure-Requests: 1” -H “Cache-Control: max-age=0”

and I tried to “clean up”, turns out they want the “compressed” argument and the user agent…

curl “http://www.brusselstimes.com/rss-feed?format=feed&type=rss” --compressed -H “User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0”

This Curl request works now.

Do you have any idea how I can force that (the user-agent and the compressed thing) through tinytinyrss ?


#4

Nevermind, I found it in the other thread

You can define SELF_USER_AGENT in config.php before it’s defined in the core and TT-RSS will use that. It’s global though so it overrides every request.

Thanks for the help.

Edit : I forgot, since I need the “compressed” option, I had to remove => curl_setopt($ch, CURLOPT_ENCODING, “”);
from functions.php


#5

Well, don’t hack the core. Just code a simple plugin to handle this feed’s quirks.

You can probably start with the Tumblr plugin from that other thread.