Tiny Tiny RSS: Community

Update error, SELF_URL_PATH


#1

So I tried installing TT-RSS when Google Reader closed down, then in 2015 then in 2016 and trying today. Every time there was some issue, (it only worked perfect once in 2012 or 2014 when i tried on windows 7 pc & xampp but I couldn’t keep that pc running just for the rss). How hard does it bloody have to be to install and run a script?

This time I am installing on Synology (i know, it says NAS is not supported) & i have managed to install + run. But running update feed gives the following error.
Please set SELF_URL_PATH to the correct value detected for your server: http://192.168.1.100/homeserver/tt-rss/
(sometimes it says, Please set SELF_URL_PATH to the correct value detected for your server: https://192.168.1.100:5001/webapi/entry.cgi)

I can not skip self url path checking as it gives error saying enable self checking.

Using php56
mariadb5
Apache2.2
updating using: php56 /volume1/web/homeserver/tt-rss/update.php --feeds

Any help is much appreciated.


#2

you can define _SKIP_SELF_URL_PATH_CHECKS in config.php which will remove this check, however the consequences may be dire (i.e. something may break, or not).

can your synology use docker? i would recommend that instead


#3

Thank you fox.

I tried finding installation instructions (specific to synology docker ttrss) but couldnt, and installed docker image & ran but don’t know how to configure it.

Does anyone have installation guide or step by step guide for docker ttrss for synology?


#4

i never actually tried running docker on DSM but the whole point is that it should not be all that specific to synology.

i.e. you should have a container with tt-rss and nginx configuration files mapped somewhere to host filesystem which you can then edit.

old version? define('_SKIP_SELF_URL_PATH_CHECKS', true); should work on recent enough git code.


#5

Thanks Fox, trying an older version.

by the way I cant skip url checking, it gives the following error.

Required configuration file parameter SELF_URL_PATH is not defined in config.php. You might need to copy it from config.php-dist.


#6

No. Fox isn’t saying he wants you to try an older version. He’s asking if you are using an older version because he wants you to use a newer one.

You’ve clearly broken something here because that should be in there from the start, even if it’s still set to the default.

In your config.php file, please add:

define( 'SELF_URL_PATH', 'http://192.168.1.100/homeserver/tt-rss/');
define( '_SKIP_SELF_URL_PATH_CHECKS', true );

You must change, in the above code, the part that says http://192.168.1.100/homeserver/tt-rss/ to replace it with the URL that you use to access TT-RSS when you want to read articles, etc.

To summarize:

  1. Update to the latest version of TT-RSS;
  2. Add the two constants to your config.php file, while;
  3. Making sure to set the correct URL on the first one.

#7

op, at this point i don’t even know if you’re using docker or not

maybe you should take a step back and start again, this time thinking things through before doing them