Tiny Tiny RSS: Community

TT-RSS installation behind nginx reverse proxy


#1

Hi to all,

i want to install an TT-RSS instance behind a nginx reverse proxy. The url the TT-RSS is externally reachably should be https://mydomain.com/ttrss/. Internal is the TT-RSS Webserver a Docker instance and reachable by ttrss-vm name.

Has someone such a setup running?
I’ve tried some configurations found via google but some working not and others working paritally. Can some post his nginx proxy configuration for that. At the moment my configuration looks like this:

    location /ttrss/ {
            proxy_pass http://ttrss-vm/;
            proxy_set_header Host $host;
    }

What makes me confused is that i have to set the SELF_URL_PATH to $http://mydomain.com/ to preserve the error:
Please set SELF_URL_PATH to the correct value detected for your server: $http://mydomain.com/

It looks like that nginx did not forward the entire url such the hostname.

When i set the URL_PATH to the suggested value i got the login site but login failed because he shortens the url to
$https://mydomain.com/index.php

For my perspective it should be $https://mydomain.com/ttrss/index.php.

Sorry for the $http:// but i can only post two URLs in one post as new user :wink:

Thanks a lot
Regards
Manuel


#2

Please use the search function or get banned by the admins.
You literally just have to type “reverse proxy” into the search and you should have your anser.

And for the next time: read the rules!
e: just noticed, the rules do not say anything about searching – this should be self-evident though


#3

You may need to pass HTTP_X_FORWARDED_PROTO from the proxy to the backend. It should contain https if the front end is connecting via SSL/TLS. It’s in the is_server_https() function, which is called on the sanity check during the initial load.

Worst case you can disable the URL checking if your setup is unique but this is not recommended unless you know what you’re doing (as these checks are there for our sanity).

e: if you’re going to run your proxy and backend with different URL structures, you’re going to have to map all that out manually. You may just want to run TT-RSS from a sub-directory in the backend. That’ll probably fix all this.


#4

@JustAMacUser
Thanks for the answer. I configured the backend to /ttrss/ and everything works fine.

Regards
Manuel