Suddenly can't log in to web interface


#1

As of this morning, I can’t log into TTRSS via the web interface any more. It immediately goes back to the blank login page after hitting the Log In button. I tried a different browser that I never use with TTRSS and it does the same thing, and it’s the same for my normal account and the admin account. I can still log in using the Android app. The web app worked yesterday.

Where can I look for error logs?

Thanks,

Phil Mercurio


#2

error logs are normally in the SQL database. you can temporarily switch log output using LOG_DESTINATION in config.php.

if you were following git trunk, roll back a few later changesets (i.e. do git log and git co c925f4e3fda for example and see if it fixes things. don’t forget to report back here.

in the future please post things like “i’m running git master” or “i’m using some package on shared hosting”. details are important to help you. see the “how to report bugs” thread for inspiration.


#3

I’ve never messed with the update settings, so I’m following the trunk. Looks like there were no code updates since 5 days ago and there are no errors in the TTRSS log, so I poked my hosting service. Turns out it was something they did, they fixed it in a few minutes. It was some security change they made, they weren’t specific about what it was.

Thanks again, and thanks for keeping RSS alive!

Phil