Tiny Tiny RSS: Community

Some Keyboard shortcuts are not working


#1

Describe the problem you’re having:

Keyboard shortcut to Toggle starred is not working.
The article is selected, I type s, nothing happens.

Also, the shortcut / to display search is not working.

Almost all the others are working fine (for example f r, f s, f q, ctrl+down, j, k).

I am using Chrome 72.0.3626.121. I tried in normal and incognito mode
I am also using Italian keyboard setting.

If possible include steps to reproduce the problem:
Select an article and hit “s”.
I am in combined mode if it might matter

tt-rss version (including git commit id):
Tiny Tiny RSS v19.2 (08183fc)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Shared hosting, PHP 7, Mysql

Please provide any additional information below:
shortcut “s” was working previously to the “great update” of the webui.

Let me know if there is some log I can provide.

Thanks in advance.


#2

Have you tried this in incognito/without browser extensions? I’m running 95e70320a6 and it’s working for me (the two commits since wouldn’t affect it since they’re just database changes).

:confused:


#3

uh-oh :face_with_raised_eyebrow:


#4

I tried in incognito mode and with no extensions enabled. It still does not work :frowning:

It was not meant in an offensive way. I just meant the shortcut has not been working for some time and is not something that changed recently


#5

I guess I have to apologize… Did not mean to insult.
I wrote that to signify that the issue I am having did not pop up recently, but has been so for some time.
I just did not have the time to report it


#6

It makes it difficult to troubleshoot when there are so many changes from the time it did work until the time it didn’t; reporting this sooner is better because it’s easier to identify the cause.

That being said, have you tried it on a different system?


#7

I agree and I am sorry.

I have only Internet Explorer available, but it just stuck at the “loading” screen after the login
explorer

edit: I installed Opera, and the “s” shortcut is not working.

At this point, I do not know if it is my installation or my machine or both


#8

Below the browser console. I select a feed, I select an article. I click “s”
Something happens only if I type “s” twice.

common.js?1544814978:20 xhrPost: {op: "feeds", method: "view", feed: "176", view_mode: "unread", order_by: "date_reverse", …}
AppBase.js?1552215612:258 RI: max_feed_id => 375
AppBase.js?1552215612:258 RI: num_feeds => 348
AppBase.js?1552215612:258 RI: cdm_expanded => true
AppBase.js?1552215612:258 RI: labels => []
Headlines.js?1552215612:545 Headlines.onLoaded: offset= 0 append= false
Headlines.js?1552215612:562 received 5 headlines, infscroll disabled= true
Article.js?1552215612:292 setActive 0
Article.js?1552215612:170 unpacking: RROW-91888
Article.js?1552215612:170 unpacking: RROW-91887
Article.js?1552215612:170 unpacking: RROW-91886
Article.js?1552215612:170 unpacking: RROW-93143
Article.js?1552215612:170 unpacking: RROW-93783
Article.js?1552215612:292 setActive 91888
common.js?1544814978:20 xhrPost: {op: "rpc", method: "catchupSelected", ids: "91888", cmode: 0}
common.js?1544814978:20 xhrPost: {op: "rpc", method: "getAllCounters", seq: 6}
AppBase.js?1552215612:258 RI: max_feed_id => 375
AppBase.js?1552215612:258 RI: num_feeds => 348
AppBase.js?1552215612:258 RI: cdm_expanded => true
AppBase.js?1552215612:258 RI: labels => []
**AppBase.js?1552215612:112 keyeventToAction s s => false**
common.js?1544814978:20 xhrPost: {op: "rpc", method: "getAllCounters", seq: 7}

#9

Do you have any system-level software running that intercepts keys? (Multiple clipboard, text-expanding, etc.)

Is there anything logged in TT-RSS on the server? (Check the logs by logging in as the admin; then Preferences > System.) You’re on shared hosting and I wonder if there is some kind of caching problem on the server side. There shouldn’t be, but …


#10

Nothing that I am aware of. I even disabled the antivirus, with no changes.
The strange thing is that almost all other keyboard shortcuts are working? Why “s” should be intercepted, while n, p, j or k not?

There are no logs in the event logger. Will try to look in CPanel if something might be related to caching, but I am not sure this is related.


#11

don’t worry about it, it just sounded funny

try opening this and see what is being returned when you type “s”: https://fakecake.org/hk-test.php
it should be keycode 38, symbol “s”.

that’s strange, it seems to map correctly to a symbol but gets eaten the first time. maybe tt-rss mistakes it for a modifier, somehow.


#12

:smile:

see below. I typed s and then what I have on my keyboard to represent /, which is either Shift+7 or / on the numeric keyboard on the right.

jQuery.Event
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnFalse()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "F12"
keyCode: 123
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "F12", code: "F12", location: 0, ctrlKey: false, …}
relatedTarget: undefined
result: true
shiftKey: false
target: body
timeStamp: 10409.63499999998
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 123
__proto__: Object
hk-test.php:23 
jQuery.Event {originalEvent: KeyboardEvent, type: "keydown", isDefaultPrevented: ƒ, timeStamp: 23673.44500000013, jQuery19103080266896420356: true, …}
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnTrue()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "s"
keyCode: 83
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "s", code: "KeyS", location: 0, ctrlKey: false, …}
relatedTarget: undefined
result: false
shiftKey: false
target: body
timeStamp: 23673.44500000013
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 83
__proto__: Object
hk-test.php:23 
jQuery.Event {originalEvent: KeyboardEvent, type: "keydown", isDefaultPrevented: ƒ, timeStamp: 45537.440000000286, jQuery19103080266896420356: true, …}
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnTrue()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "k"
keyCode: 75
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "k", code: "KeyK", location: 0, ctrlKey: false, …}
relatedTarget: undefined
result: false
shiftKey: false
target: body
timeStamp: 45537.440000000286
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 75
__proto__: Object
hk-test.php:23 
jQuery.Event {originalEvent: KeyboardEvent, type: "keydown", isDefaultPrevented: ƒ, timeStamp: 163875.5450000001, jQuery19103080266896420356: true, …}
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnTrue()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "/"
keyCode: 111
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "/", code: "NumpadDivide", location: 3, ctrlKey: false, …}
relatedTarget: undefined
result: false
shiftKey: false
target: body
timeStamp: 163875.5450000001
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 111
__proto__: Object
hk-test.php:23 
jQuery.Event {originalEvent: KeyboardEvent, type: "keydown", isDefaultPrevented: ƒ, timeStamp: 172530.93000000014, jQuery19103080266896420356: true, …}
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnTrue()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "Shift"
keyCode: 16
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "Shift", code: "ShiftRight", location: 2, ctrlKey: false, …}
relatedTarget: undefined
result: false
shiftKey: true
target: body
timeStamp: 172530.93000000014
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 16
__proto__: Object
hk-test.php:23 
jQuery.Event {originalEvent: KeyboardEvent, type: "keydown", isDefaultPrevented: ƒ, timeStamp: 172915.4799999999, jQuery19103080266896420356: true, …}
altKey: false
bubbles: true
cancelable: true
char: undefined
charCode: 0
ctrlKey: false
currentTarget: document
data: undefined
delegateTarget: document
eventPhase: 3
handleObj: {type: "keydown", origType: "keydown", data: undefined, handler: ƒ, guid: 16, …}
isDefaultPrevented: ƒ returnTrue()
isPropagationStopped: ƒ returnTrue()
jQuery19103080266896420356: true
key: "/"
keyCode: 55
metaKey: false
originalEvent: KeyboardEvent {isTrusted: true, key: "/", code: "Digit7", location: 0, ctrlKey: false, …}
relatedTarget: undefined
result: false
shiftKey: true
target: body
timeStamp: 172915.4799999999
type: "keydown"
view: Window {postMessage: ƒ, blur: ƒ, focus: ƒ, close: ƒ, parent: Window, …}
which: 55
__proto__: Object

#13

it seems that this works like it should. just to confirm, does hk-test.php contents show proper mappings? i.e.

Keycode=83, Symbol=s, Shift=false, Alt=false, Ctrl=false

should appear when you type “s”. if it does, i’m out of ideas. :frowning:

e: check that “s” mapping exists in keyboard shortcuts help (under Article).

also in tt-rss f12 console check that this matches:

03eOizGG


#14

I read about this commit so I git updated and I am now running Tiny Tiny RSS v19.2 (63d7705).
I tried the keyboard shortcut “s” and it did not work. I tried “S” (Toggle published) and it did work
So I disabled all the plugins and “s” worked again.
I re-enabled one by one and once I activated “wallabag_v2” the “s” keyboard stopped working.
I have no idea why, but it’s either the plugin off or no shortcut.
I will open an issue on the plugin’s project if someone else can confirm this behavior.

I had to update the plugin
Sorry for not figuring out earlier by myself.