[Solved] Feeds updating but error saying they're not


#1

Describe the problem you’re having:

I keep getting a popup at the bottom of my feeds stating “Update daemon is not updating feeds”.

notupdating

Update daemon is taking too long to perform a feed update. This could indicate a problem like crash or a hang. Please check the daemon process or contact instance owner. Last update: 2018.08.24, 12:23

This does not seem to be the issue from what I’m seeing as my update script php update_daemon2.php appears to be running fine (see below). I also see fresh feeds in my “Fresh Articles”

15:49:06/23520] Scheduled 0 feeds to update…

[15:49:06/23520] Sending digests, batch of max 15 users, headline limit = 1000

[15:49:06/23520] All done.

[15:49:07/19894] [reap_children] child 23516 reaped.

[15:49:07/19894] [reap_children] child 23517 seems active but lockfile is unlocked.

[15:49:07/19894] [SIGCHLD] jobs left: 0

[15:49:07/19894] [SIGCHLD] jobs left: 0

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

  • mysql Ver 14.14 Distrib 5.7.23, for Linux (x86_64) using EditLine wrapper
  • PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS )

#2

check permissions on lock/ directory, remove stamp/lock files if necessary, make sure they are being created properly afterwards


#3

Worked.

Permissions were okay but something was up with the “update_daemon.stamp”. Removing and restarting the update fixed it.

Thanks.