Match a filter keyword against several categories


Is there a way to match one filter keyword across several categories? In the example below I’d like to have foobar matched against titles in categories Newspapers and Magazines.

Of course, I could just duplicate the rule, but there may be a more elegant solution.


nope. i guess a comma-separated list could work here, main problem is dojo dropdown list thing.

e: unfortunately this doesn’t work with current schema :frowning:


No worries. The filters are great as they are. I’ll just duplicate.


this would be a legit good feature to have tho


heads up, i guess, this is now in trunk (0bf7e007)

report here if filters and maybe everything else is broken

e: oops, i forgot to merge in schema updates.


Fantastic. You’re a wizard, fox.


Hello, I just tried create filter and this is what “Add rule” window look like:

And if I click to feed list or press any key:

I tested in in Chrome and Edge, in both, it looks exactly the same.

It has to look like this? Thanks


No, it doesn’t. Looks fine in Chrome, Firefox, Opera, and Safari here on macOS Sierra. I wonder if the glitch may be caused by your browser’s zoom setting or your screen’s DPI setting.


Thanks, its strange. I have DPI set to 100% (on Windows 10). I just tried view TTRSS on remote desktop (IE11) and it look same.
It is not possible that I have something wrong with TTRSS installation? I always do update with git pull origin master.


I see the same “problem” on MacOS El Capitan with Chrome 59 and Safari 10.1.1. The window changes when you click on one of the feeds in the lower part of the window.


do you have any super long feed names? maybe that’s what’s screwing it up and its unrelated to the platform


Helo, you’re right. I think I have too long feed titles
My longest name was 194 characters long I cut him off but it did not help.
Then I have a large number of feeds with about 140 characters. So this could be the length that causes the problem.


It is definitely the length of the feed titles. I had a couple of long ones. After truncating them the issue disappeared.


should be easy to fix then


Hello, I just do did update to version b2d42e9, reboot and tried it in chrome anonymous window - still same problem.

Edit: I’m so stupid


what if you read before posting



fox: Sorry my bad. I swear I’d read “it should be fixed now” :slight_smile:
I apologize once again.

After running update, problem is now solved, thank you!