Tiny Tiny RSS: Community

MariaDB Master Master


#1

Hello

I juste switched from a single Mysql server to 2 MariaDB servers in master master replication.

The rate of creation of content into the DB by TTRSS is breaking the replication.

Do I miss something or is it a normal behavior ?

Thanks for help


#2

So data is changed too quickly and replication doesn’t like it, sounds like a poor replication system to me honestly. Any half decent system wont care, it’ll just replicate the changes and that’s it.

Can’t say I’ve delved into SQL repication much, assuming TTRSS is pointing to one server, any changes should be tracked in transaction logs which are then replayed on the 2nd server.
Unless there is some kind of log limit where the volume of changes exceeds this limit. Then I’d be looking at expanding this limit somehow. Also if this is because replication is too slow to keep up, how are they connected, are you doing replication over a slow link?

You’ll need to provide a lot more info to get any kind of answer, I’ve never seen anyone run replcation for TTRSS before. How is it configured, versions, etc, etc.

Have you also tried looking up general MariaDB/SQL replication issues?, it’s unlikely to be TTRSS causing this just by the nature of how replication works…


#3

Thanks for helping

I have other DB on MariaDB without any issue with sync.

The sync is a master master …classical settings

The sync crash almost in minutes btw. Don’t think it’s a log issue.

Debian Strech
MDB 10.X (latest version)

Thanks


#4

Sync doesn’t care about the actual data in the log, the only thing that could cause the issue is the volume of data, if that is the cause then if you added other things to the database you would eventually hit the same problem.

Take a look at this, may help:

Suggest you investigate sync crash issues in general.


#5

I’ll look into that one (apparently putting it to 20 resolves the issue) but … I don’t have at all this setting for the time being.

Thanks again for you help :slight_smile: