Tiny Tiny RSS: Community

Error when trying to use TT RSS UI or update


I’m upgrading to PHP 7.2 and keep getting an error:
Tiny Tiny RSS was unable to start properly. This usually means a misconfiguration or an incomplete upgrade.
Please fix errors indicated by the following messages:

  • PHP support for hash() function is required but was not found.

If possible include steps to reproduce the problem:
Load the login page.

tt-rss version (including git commit id):
lastest on Github

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Ubuntu 12.04.5 LTS
PHP 7.2
MySQL 5.6.

Please provide any additional information below:
Also happening when running update.php


http://php.net/manual/en/hash.installation.php indicates that hash() should be there by default…

# php -v
PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.10-0ubuntu0.18.04.1, Copyright (c) 1999-2018, by Zend Technologies
# php -r "echo function_exists('hash').\"\n\";"
# php -m | grep hash


Both of these come up blank

# php -r "echo function_exists('hash').\"\n\";"
# php -m | grep hash


Lastly, try dumping information looking for hash:

$ php -i | grep hash
hash support => enabled
phar.require_hash => On => On


I had to enable the extension in php.ini. It looks like my web host disables it by default for some reason.

Now it passes all of these tests. Updates are working but the web page still says the same thing. Is there another location to specify the path to php other than define(‘PHP_EXECUTABLE’, ‘[path to php]’); in config.php and update.php? It’s odd to me that the PHP path in both files is set to the same thing but only update.php works.


… you did restart your webserver (or whatever’s running php) after changing php.ini, didn’t you?


I did but what I didn’t do was save the new path in the file before I restarted the webserver. It’s all fixed now. Thank you for your help. Happy Friday!