Tiny Tiny RSS: Community

Error: "Failed to parse output. This can indicate server timeout and/or network issues. Backend output was logged to browser console."


#1

Describe the problem you’re having:

Unable to subscribe to this feed (removing ‘s’ from https or cleaning cookies doesn’t help either): https://kentakademisi.wordpress.com/feed/

If possible include steps to reproduce the problem:

Open tt-rss, try to subscribe said feed, got this error: “Failed to parse output. This can indicate server timeout and/or network issues. Backend output was logged to browser console.”

I have tried fox’s ‘myfeedsucks’ tool and it got parsed successfully, which means the problem lies in my installation.

tt-rss version (including git commit id):

v17.4 and the last commit was 485902c3

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

OpenShift platform, Cron 1.4, PHP 5.4, PostgreSQL 9.2, phpPgAdmin 5.0

Please provide any additional information below:

Said error stated that backend output was logged to browser console. This is what web console in Firefox says when I try to subscribe to the feed:

op=rpc&method=addfeed&feed=https%3A%2F%2Fkentakademisi.wordpress.com%2Ffeed%2F&cat=1&login=&pass= MY-TT-RSS-URL.com:234:66

I’ve also tried different browsers.

Any help is most appreciated!


#2

Do you have any PHP logs? If you haven’t changed the default settings TT-RSS logs errors to the database and you can view that in the admin user’s Preferences section. Might also be available in normal server logs (/var/logs or whatever your OS flavour uses).

I have experienced similiar (but not exact) error messages in my development environment when all of PHP-FPM’s child processes are busy for so long the request just times out. But you never stated you were using PHP-FPM and I don’t know what your setup uses.

One thing to try is to SSH into the server and try using curl or something similar to see if the URL times out. I have experienced times where some sites have blocked entire subnets, so if curl from the terminal doesn’t load it, you know not to waste your time with your web stack.


#3

i have no idea if openshift has ssh access but if it does try logging in and downloading the feed with wget

e: beaten


#4

Thanks both for the answers. I’ll try and do your suggestions over the weekend. In the meantime, I narrowed down my problem to ‘https’ links e.g. https://discourse.tt-rss.org/posts.rss produces the same error message. Cheers.


#5

well maybe some certificate bullshit on openshift then? i.e. outdated package with letsencrypt certs missing.


#6

Just in case a lost soul in the future is sent to this thread by Google: I exported my feeds as .opml to my computer and added any https feed links giving me trouble manually to .opml file and then imported it back again. This does not only circumvent the problem, but actually solved it i.e. I tried to add another https feed to ttrss using main web interface and it was subscribed without any problem. I reckon seeing my laughable fix to the problem, Openshift gods must have corrected whatever the issue was - or, it was a coincidence. Anyways, cheers for the help and hope this helps anyone who might happen to have the same problem in the future.


#7

you can also try batch feed adding (in the prefs dropdown), it also does not do any validation on the urls


SSL Error when trying to add blog post