Associated Press (AP) News plugin


#1

AP News no longer provides RSS feeds. This plugin provides virtual AP News feeds based upon JSON used by their website.

Quick use: install the plugin, subscribe to a “feed” using a URL like https://apnews.com/tag/apf-topnews or https://apnews.com/tag/apf-topnews,apf-usnews .

Source and details @ https://github.com/supahgreg/ttrss-apnews

NOTE: This plugin needs tt-rss from 2017-10-01 or later (specifically: 0f0d6ca559).


Newspaper feed blocked in ttrss? [SOLVED]
#2

Thanks. But what makes you believe the AP has ditched RSS feeds? They seem to be there.


#3

Interesting, thanks. The ones I had been using were removed, and I somehow missed that page.

I suppose the main benefit of this plugin now is generation of feeds based upon AP News tags, which give much more fine-grained control and flexibility than the official feeds.


#4

To be fair, that AP’s webpage is all new. I remember their feeds were listed on a page with totally different, more colourful design. Which means the AP have been messing with the feeds, and I suspect it’s in the direction of marginalizing them. So, your plugin may yet become useful to those unwilling to migrate to Twitter and its ilk.


#5

I was excited that someone found some AP feeds after the ones I subscribed to were removed, and while the feeds on that page work, the links in the entries are broken so they are not useful.


#6

The Associated Press seems to have removed the feeds. So, I turned back to the plugin, but it doesn’t work:

Couldn't download the specified URL: HTTP/1.1 200 OK

I’m on f530224

Any ideas how to fix it?


#7

I too have been frustrated with the loss of AP’s RSS feeds. As you said, the plugin no longer works.

I use a feed43 proxy RSS feed to get around a GDPR block on a local newspaper’s RSS feed (see this discussion) so I tried setting up a proxy for the AP Top News feed. Unfortunately, the AP site uses javascript to generate the article list and there’s nothing on the feed43 site about how to set up a proxy in that case.

Hopefully someone with more technical skills than I can come up with a way to convert the AP news feed pages to an RSS feed that TT-RSS can work with.


#8

See what you get by hitting the AP News API directly from wherever tt-rss is running (and/or your local system if in a similar region). For example, https://apnews.com/tag/apf-topnews corresponds to https://afs-prod.appspot.com/api/v2/feed/tag?tags=apf-topnews . I wonder if you’re running into something related to GDPR, as I’m still using the plugin without issue.


#9

Thanks for your reply @wn_name. I’m not sure what you mean by ‘hit the AP News API directly’… ?

Assuming you mean enter the apnews URL in my browser window – a page opens on the AP site with the feed specified in the URL. However, when I attempt to subscribe to that page in TT-RSS (with your plugin activated), I get the same error as @mamil ("Couldn't download the specified URL"). When I attempt to subscribe with the plugin disabled, I get a different error: "Specified URL doesn't seem to contain any feeds", which is presuably why you created the plugin.

I’m in the US but I’m using Marc Gerges’s instance of TT-RSS that resides on a server in Europe. Marc installed your plugin yesterday at my request. But this doesn’t look like a GDPR issue. I experienced a GDPR block on a local newspaper’s RSS feed and in that case, I got a very different error:

451: Unavailable for legal reasons

I suppose it’s possible AP is blocking the requests but fails to send back an error code.


#10

Thanks, wn. Doesn’t look like GDPR. Both URLs open just fine. One leads to the AP webpage, the other to something which looks like this (API?):

{
  "cards": [
    {
      "textScale": null, 
      "headlineWidget": null, 
      "expandedStoryCount": null, 
      "tagObjs": [], 
      "sponsorImageUrl": null, 
      "contents": [
        {
          "embedHTML": null, 
          "embedHeight": null, 
          "contentSponsor": null, 
          "tagObjs": [
            {
              "order": 1, 
              "id": "apf-topnews", 
              "name": "AP Top News"
            }, 

I’ve noticed that if I replace https with http, I don’t get the 200 error. TTRSS accepts the URL and I can ‘subscribe’, but then the first update attempt yields this:

fetch error: LibXML error 4 at line 1 (column 1): Start tag expected, '<' not found