Tiny Tiny RSS: Community

Android: Connects to account but no feeds present


#1

Describe the problem you’re having:
The Android app will connect to my account, but no feeds or categories appear. The same thing happens in my mobile browser, but on my PC my feeds are all there.

If possible include steps to reproduce the problem:

tt-rss version (including git commit id):

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
The server is the current FreedomBox version. Android app is the current Play store version.

Please provide any additional information below:


#2

there’s built-in log viewer in app preferences, check for errors there

this seems like a network issue then
unlikely if you’re using SSL but you might be getting MITMed by your mobile ISP which breaks tt-rss JSON data

i have no idea what that is but make sure it allows connections from your mobile network, alternatively try using a different connection (wifi)


#3

FreedomBox is a Debian “pure blend” made for SBCs, with one- click installs for several servers including TTRSS.

The problem is definitely not with my mobile ISP, as I’m connecting via wifi on the same router my Pi (the machine running the server) is plugged into. And again, the app is connecting to the server and logged into the account, it’s just not getting the content I’ve added.


#4

if you’re not going to post any logs you might as well not post at all because we won’t be able to help you

that might include nginx logs, tt-rss event log, etc


#5

Hey, thanks for welcoming me to the community.