A few odd 404 errors


#1

I caught a few odd 404 errors in the apache access logs.
Using the latest git version.

xxx.xxx.xxx.xxx - - [26/Mar/2018:05:14:06 +0200] “GET /%22%22+getInitParam(%22icon_indicator_white%22)+%22/%22 HTTP/1.1” 404 581 "https://ttrss.info/index.php?" “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:14:06 +0200] “GET /%22%22+getInitParam(%22icon_cross%22)+%22/%22 HTTP/1.1” 404 758 "https://ttrss.info/index.php?" “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:14:06 +0200] “GET /%22%22+getInitParam(%22icon_alert%22)+%22/%22 HTTP/1.1” 404 758 "https://ttrss.info/index.php?" “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:14:06 +0200] “GET /%22%22+getInitParam(%22icon_information%22)+%22/%22 HTTP/1.1” 404 758 "https://ttrss.info/index.php?" “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:25:32 +0200] “GET /%22%22+getInitParam(%22icon_indicator_white%22)+%22/%22 HTTP/1.1” 404 581 “https://ttrss.info/” “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:25:33 +0200] “GET /%22%22+getInitParam(%22icon_information%22)+%22/%22 HTTP/1.1” 404 758 “https://ttrss.info/” “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko)
Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:25:33 +0200] “GET /%22%22+getInitParam(%22icon_cross%22)+%22/%22 HTTP/1.1” 404 758 “https://ttrss.info/” “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”
xxx.xxx.xxx.xxx - - [26/Mar/2018:05:25:33 +0200] “GET /%22%22+getInitParam(%22icon_alert%22)+%22/%22 HTTP/1.1” 404 758 “https://ttrss.info/” “Mozilla/5.0 (X11; Linux) AppleWebKit/538.15 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.15 Midori/0.5”


#2

sounds like you had a client with a particularly broken browser
unless this happens all the time


#3

I have checked all the access logs now and not seen it previously.
Thanks @fox