Tiny Tiny RSS: Community

V. 18.12 - new installation - shortcut key behavior


#1

Hello,

I’ve just installed TinyRSS using my hosting company’s (Reclaim Hosting) cPanel instance. It is very fast and responsive! However, four of the shortcut keys (listed below) do not respond as I would expect:

n - Open next article

down - Open next article

p - Open previous article

up - Open previous article

For example, when a given feed is selected with 10 unread articles, selectingn or down scrolls through the first post until the end of the article is reached instead of opening the next article. Conversely, selectingp or up scrolls an article up until the beginning of the article is reached instead of opening the previous article.

All of the other shortcuts that I have tried seem to work as described. And this leads me to believe that I may just be misunderstanding how these shortcuts work.

I am able to provide the system details below which, unfortunately, do not match the precise details described in the Read before posting article. I apologize for this. I can contact my hosting service to try to obtain the linux distribution and other details if they would help.

tt-rss v. 18.12

Platform linux

Mysql 10.1.38-MariaDB

PHP v 7.0.33

Architecture x86_64

Kernel 3.10.0-714.10.2.lve1.5.17.el7.x86_64

cPanel 76.0 (build 20)

If you have any advice on what I may be missing or how to troubleshoot this, I would appreciate it.

Will


#2

that’s how those have always worked, the idea is you can keep pressing one button to go down/up while going through all content without missing anything

if you want to always jump to next/previous article use “don’t scroll” hotkey variants
if you want to use those by default, you can map them to n/p by making a very simple plugin (maybe we should have one bundled)


#3

Thank you for your reply! I tried out both the hotkey plugins that were available in the plugins directory. The google reader plugin seemed promising since it indicated that it had a “don’t scroll” function. But in practice, it seemed to work in the same way.

If there are other possible plugins I might try that have the “don’t scroll” option, I would love to hear suggestions.


#4

i suppose this could be useful to other people


#5

Thanks for sharing this. Just did the following:

  1. Uploaded init.php from Github to plugins\hotkeys_noscroll in my root for tt-rss
  2. Went to Preferences > Plugins and enabled hotkeys_noscroll
  3. Attempted to use the n, p, and up, down hotkeys.

I did not notice any change. I must be missing something very simple. But my new installation of tt-rss does not appear to be responding to the plugin.

Thanks, anyway.


#6

first of all you should have just git pulled, it’s in the stock repo

as to why it doesn’t work for you idk


#7

He is using cPanel…


#8

That is correct. And the version number is listed in my original post, if that’s useful.


#9

When using the Google Reader keyboard shortcuts plugin -

  • j = Next Article , Don’t Scroll.
  • k = Previous Article , Don’t Scroll.
  • N = Next Feed
  • P = Previous Feed
  • v= Open Article in new Tab/Window

Hope that helps.
Mark,


#10

@markwaters thanks for mentioning the Google Reader keyboard shortcuts plugin. I gave it a try but the behavior remained the same. The only plugin that has had an effect was the jk swap plugin.


#11

they all work in exactly same way, i find it hard to believe one would work while others don’t.