Use less traffic & Do not embed images config options


Tiny Tiny RSS v17.12 (1ddf3a2), ‪Ubuntu 14.04.5 LTS‬, PHP 7.0.27, PostgreSQL 9.6.6, curl 7.35.0

Is there a way to disable or always check “Use Less Traffic” as default through the config file? I can easily remove it from the code / edit login, but just wanted to know if there’s an easier way to avoid custom editing of core files.

Asking as I once forgot and it slowly killed my server, I believe it was CPU related and it also got worse and worse after hours, e.g 20% CPU for an initial period of 1-5 hours then 30% for hours, then 40% and so on.

Update: A second question would be if there’s a way to make “Do not embed Images” the default for all newly created feeds. Unless I am wrong I always set this manually even if I do have “Do Not Embed Images in articles” set via Preference. I was for a while thinking they are linked, maybe the one overrides the other?


The option is labelled Use Less Traffic not Use Less CPU.

That being said, I can see no reason for the CPU issues you’re experiencing being caused by not using the less traffic option. In fact, it should be the other way around because TT-RSS has to do more work to filter the images out (although the extra CPU load would be negligible). The point of the option is to reduce traffic; it’s useful–among other things–when you’re on mobile so you don’t use unnecessary allocation, which tends to be limited on those devices.

Did you run top or anything when your server was experiencing this issue to see what was going on? It doesn’t sound like something TT-RSS would cause, though I could see errant PHP processes sucking like that.

If I had to take a guess it would be something with your 70 GB database, but who knows. :man_shrugging:t2:

You could actually force everything to hide images using a plugin on HOOK_SANITIZE. If you look at the sanitize function you can see how it does it. Then you’d never need to change any settings as the plugin would make sure it’s done. Again though, it won’t fix your CPU issues.


Thanks for feedback, hmm that is weird, But yes I had one browser on a PC logged on without checking the box. As soon as that got closed down the situation resolved itself. As it happens it seems like I did grab two related screenshots that day, including a HTOP. Not sure if it helps make anything clearer.

For reference the server is a running Intel Xeon CPU D-1521 @ 2.40GHz (8 cores)

This was my HTOP view when I noticed issues after a week (there’s a small normal bit on Fri night, then the browser was up since Fri morning until I sorted things late Thursday):

This was how it looked in PLESK for that week (seemingly growing bigger each day, both user and system wise). Not a 100% on the dips down, that said the PC is often slept each night 8-9h time) but not all days.

This is how it looks in PLESK now for the last week

I should in theory be able to reproduce this if needed, though I am confused as to what happened. I’ll have a look at that plugin. I mainly want to ensure nothing is “embedded” nor downloaded as I don’t need images in general.