Tiny Tiny RSS: Community

Uncaught PDOException: There is already an active transaction


#1

Describe the problem you’re having:
When running update.php, I receiving a mssql error

If possible include steps to reproduce the problem:

/usr/bin/php /var/www/XXXX/rss/update.php --force-update
[08:57:25/20462] Lock: update.lock
[08:57:25/20462] marking all feeds as needing update...


/usr/bin/php /var/www/XXXX/rss/update.php --feeds

[08:57:30/20463] Lock: update.lock
[08:57:30/20463] Scheduled 114 feeds to update...
[08:57:31/20463] Base feed: <removed>
[08:57:31/20463]  => 1970-01-01 00:00:00, 8 1
[08:57:32/20463]     1.7982 (sec)

[...]

[08:59:22/20463] Base feed: <removed>
[08:59:22/20463]  => 1970-01-01 00:00:00, 176 1
[08:59:23/20463]     1.1146 (sec)
[08:59:23/20463] Processed 114 feeds in 112.2023 (sec), 0.9842 (sec/feed avg)
[08:59:23/20463] Running housekeeping tasks for user 1...
[08:59:23/20463] Sending digests, batch of max 15 users, headline limit = 1000
[08:59:23/20463] All done.
[08:59:23/20463] cache/simplepie: removed 0 files.
[08:59:23/20463] cache/feeds: removed 0 files.
[08:59:23/20463] cache/images: removed 0 files.
[08:59:23/20463] cache/export: removed 0 files.
[08:59:23/20463] cache/upload: removed 0 files.
[08:59:23/20463] Removed 0 old lock files.
[08:59:23/20463] Removing old error log entries...
PHP Fatal error:  Uncaught PDOException: There is already an active transaction in /mnt/www/XXXX/rss/classes/rssutils.php:33
Stack trace:
#0 /mnt/www/XXXX/rss/classes/rssutils.php(33): PDO->beginTransaction()
#1 /mnt/www/XXXX/rss/classes/rssutils.php(1516): RSSUtils::update_feedbrowser_cache()
#2 /mnt/www/XXXX/rss/update.php(167): RSSUtils::housekeeping_common(true)
#3 {main}
  thrown in /mnt/www/XXXX/rss/classes/rssutils.php on line 33

tt-rss version (including git commit id):
5f66f872b6ddf5d3b70504fd870e6c4de69c1d19 (git pull reports Already up-to-date.)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Ubutnu 16.04.5
mysql-server-5.7

PHP 7.0.32-0ubuntu0.16.04.1 (cli) ( NTS ) Copyright (c) 1997-2017 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies with Zend OPcache v7.0.32-0ubuntu0.16.04.1, Copyright (c) 1999-2017, by Zend Technologies


#2

first, open tt-rss errror log in preferences and look if there’s any other errors logged, before that one happened

there’s probably not going to be any but just in case


#3

Just the same Error-Message:

E_USER_NOTICE (1024)

/mnt/www/XXXX/rss/classes/rssutils.php:587

There is already an active transaction
#0 /mnt/www/XXXX/rss/classes/rssutils.php(587): PDO->beginTransaction()
#1 /mnt/www/XXXX/rss/classes/rssutils.php(192): RSSUtils::update_rss_feed(‘57’, true, false)
#2 /mnt/www/XXXX/rss/update.php(166): RSSUtils::update_daemon_common()
#3 {main}

Thanks


#4

most likely something happened during that particular feed update which caused a PDOException during an open transaction (i.e. two exact same articles were processed at the same time by multiprocess updater), currently updater code doesn’t handle this very well.

i think i have a bit of an improvement for this in trunk:


#5

thanks, works now for me

great support