Synology station: Rss updates fail when the rss feed is an httpS


#21

Hi @fox,

With DSM you do that in Webstation configuration. I am pretty sure I have enabled CURL but let me check once more and send the PHP -i information. If that doesn’t work, I will just do a fresh install of DSM and will use one of the threads in here. I have used this guide:


#22

In my own personal experience, if http is working, but httpS isn’t, the system often just has a problem with SSL.

If the shell of the system has wget or curl, you can try just accessing an https url to make sure you get valid data.

Maybe just ‘wget https://google.com’ or 'wget https://GitHub.com
If one site works, try accessing your https feed urls with it to make sure they also work.

By no means exhaustive, but the most common solutions for me have been:

  1. Make sure the date and time are set and correct, within a few hours at least.
  2. Update CA Certificates. This can sometimes be done with a package manager or normal update process, but some systems you have to update this manually.
  3. Most recently, a hard requirement of a CentOS5 system meant I also had to compile a new OpenSSL and wget, and update cacerts manually to access directly. Supporting extended LTS stuff sucks sometimes.

#23

CentOS-5 has an End of Life date of March 31, 2017… Hope that was before that. :slight_smile:


#24

Unfortunately not, though it is just the build environment at least. They moved the code from subversion to a very new version of git. CentOS5 does not ship with git, at all. The build environment normally doesn’t get touched, but we added git to it. :confused:


#25

What could go right⸮

\stops highjacking the thread.


#26

I had reached the maximum posts on one day so I couldn’t reply any longer yesterday. I did a clean install of DSM and TTRSS and everything is working fine now. I guess the DSM was corrupted.
Thank you everyone! :slight_smile:


#27

For anyone else coming this way who doesn’t want to re-install their DSM, I found another solution that works (or did for me).

If you follow the steps in the previously linked guide (https://www.reddit.com/r/synology/comments/6a27sd/step_by_step_guide_to_installing_tiny_tiny_rss/) you’ll be using php56 for everything. What I found was that despite the php settings panel saying it was installing the openssl, curl, and sockets modules for php56, they were going in the base php modules directory and configuration. What I did to fix this:

sudo cp /usr/lib/php/modules/openssl.so /usr/local/lib/php56/modules/
sudo cp /usr/lib/php/modules/sockets.so /usr/local/lib/php56/modules/
sudo cp /usr/lib/php/modules/curl.so /usr/local/lib/php56/modules/

Then open up /usr/local/etc/php56/php.ini and add:

extension = openssl.so
extension = curl.so
extension = sockets.so

And that should hopefully fix it. Don’t know for sure that curl and sockets are needed, but seemed relevant so I added them.