Switch updating to git, and not PPA?


#1

How do I switch to updating via git (git pull origin master), and not the PPA?
It seems the webupd8 PPA is outdated (tt-rss v15.7 versus 17.4 on git).

Also note, I originally tried the setup from git, but then switched to the PPA for simplicity.

I tried “sudo git pull origin master”, but didn’t seem to update. The version of Preferences still says v15.7, and git release is 17.4.

jake@BROWN:/var/www/html/tt-rss$ sudo git pull origin master
From https://tt-rss.org/git/tt-rss
 * branch            master     -> FETCH_HEAD
Already up-to-date.

Is there a way to reconfigure git?
Or is git downloading files somewhere else (not sure how it knows where to store the files, and maybe there’s another git repository somewhere else on my system)?

Thanks.


#2

I searched the forum for git and found this thread that addresses your question:


#3

At this point, you might as well get a clean install and restore data…


#4

keep the database (dump it first to be sure!) and config.php, purge all tt-rss packages and any leftover files, then git clone from scratch.


#5

Thanks…I wiped everything out and started over.