Startup failed mcrypt error


#1

I’ve been running TT RSS for over a year and it’s been excellent. No issues. But I’ve now broken it and need some help.
I updated PHP to 7.2 to support another application on my server and then discovered it broke TT RSS and I now have the error with the startup failed message
> Startup failed
> Tiny Tiny RSS was unable to start properly. This usually means a misconfiguration or an incomplete upgrade. Please fix errors indicated by the following messages:
>
> FEED_CRYPT_KEY requires mcrypt functions which are not found.
> You might want to check tt-rss wiki or the forums for more information. Please search the forums before creating new topic for your question.

I’ve read through the forums, reverted back to PHP 7.0 and have tried to running “update.php --decrypt-feeds and then set FEED_CRYPT_KEY to an empty string.” As outlined in the FAQ’s

I’ve tried this via browser url and via console in phpMyAdmin. I’m struggling to invoke this > --decrypt-feeds and then set FEED_CRYPT_KEY to an empty string.

I’d really appreciate a layman’s guide in simple terms how to resolve this.

Thanks in advance

/Mark


#2

Do your feeds automatically update, if so then how, figure that out and it’ll be a clue on how to run the update.php command. You don’t run it in a browser (since when do browsers get command line arguments??) or phpmyadmin (same thing).

You have to run as php in command line, since you’ve posted no info on your setup you’ll need to figure that out yourself, but finding how you’ve setup feeds to auto update, maybe reading that part of the FAQ, will help…

Read this, https://git.tt-rss.org/fox/tt-rss/wiki/UpdatingFeeds


#3

Right idea… you want to run that in the directory TT-RSS resides using SSH/Terminal.

  1. Roll back to PHP less-than 7.2.
  2. In a Terminal/SSH run:
cd /path/to/tt-rss
php update.php --decrypt-feeds
  1. Set the FEED_CRYPT_KEY to '' in config.php.
  2. Update to PHP 7.2

#4
  1. do you have any password protected feeds? if not you don’t need to run --decrypt-feeds.
  2. you need to edit config.php on your server, it’s in tt-rss directory. alternatively download the file via FTP or any other way, edit it, and upload it back.

also going by your post you look like a shared hosting user. am i right? i mean otherwise i’m not sure how any of these, especially editing a text file, could possibly be a problem.


#5

Thank you for the input and help

To add some more info

I can now login again

Yes feeds are automatically updated, they are not password protected, they are mainly feeds directly from sites or google news

Yes, s

hared server.

I ran update.php
updated config.php on server, edited this:
define(‘FEED_CRYPT_KEY’, ‘[mod note: redacted]’);
to
define(‘FEED_CRYPT_KEY’, ‘’);

changed PHP version to 7.2, and compiled with required modules, see attached

Feeds have not updated and I now have this error on the System Error Log:

E_WARNING (2) classes/pref/prefs.php:836 count(): Parameter must be an array or an object that implements Countable

  1. classes/pref/prefs.php(836): ttrss_error_handler(2, count(): Parameter must be an array or an object that implements Countable, classes/pref/prefs.php, 836, Array)
  2. backend.php(123): index()

similar or same as per this topic Feed updating broken with php7.2

If it’s any help and it is easier to resolve these issues, I do not need to run PHP 7.2 I could run 7.0 or 7.1,


#6

you’ve updated php but you’re running an old (unspecified) version of tt-rss, you need to update that too. the method for updating would depend on how you had it installed (also unspecified).

you really need to start paying more attention to your posting, specifically versions of everything.


#7

Couple things: I moved your post to unsupported because you’re on shared hosting. I also removed the mcrypt key from your post. I don’t know if you use that as a password elsewhere (you shouldn’t), but it’s not needed and you shouldn’t post that type of stuff on a public forum.

I’m thinking you’re not running the latest version of TT-RSS. In fact, you might not even be running it directly from the git repository.

Can you please provide the version and commit id for your TT-RSS install?

e: Please read https://discourse.tt-rss.org/t/read-before-posting-reporting-bugs/120


#8

Have done a clean install v17.12 from git. All feeds updating. All is good.

Apologies for my ignorance and lack of knowledge on TT-RSS and thanks to all who gave support.