Tiny Tiny RSS: Community

SSL Error when trying to add blog post


#1

I am trying to add a particular RSS and it fails.

Couldn’t download the specified URL: 51 SSL: no alternative certificate subject name matches target host name 'blogs.office.com
This occurs when i try to add https://blogs.office.com/en-us/feed or similar Microsoft posts.

Is there a way to override the SSL checks so that it does not fail at this point? There are numerous Blogs at Microsoft that i want to include in my RSS and its failing to.

Environment:
PHP Version 5.5.25
Tiny Tiny RSS v17.4

PS. The iOS and Web app is fantastic and am really glad to have tried it.


#2

This type of error is a result of the the operating system’s SSL support, as that’s what TT-RSS uses (i.e. it’s not actually an error specific in TT-RSS). I didn’t seem to have the issue on my Debian system when I tried the URL. What operating system (and version) are you using? Your version of OpenSSL may be out of date.

Try using curl from SSH and see what the result is:

curl -LI https://blogs.office.com/en-us/feed

#3

If you want to circumvent the TT-RSS URL validation, this might help: Error: "Failed to parse output. This can indicate server timeout and/or network issues. Backend output was logged to browser console."


#4

it likely won’t get updated though so there’s not much point in it


#5

Thanks for the suggestion. I tried it on Centos 5 and it failed. Centos 6 host worked so ill migrate the site to a differnet server and do further testing.

Appreciate the assistance - i will report back with final solution however suspect this is it. As mentioned most likely out of date OpenSSL version in OS.


#6

Migrating to a new server resolved the issue. I didnt spend a great deal of time working out what it was, but i would put it down to not using the latest version of back end, most likely Centos.
Successfully added feeds without any error prompts.

Thanks for your assistance.


#7

CentOS 7 has been out for a while now…