Tiny Tiny RSS: Community

Some problem with SSL


#1

I try subscribe to https://blog.servo.org/feed.xml
And get this error:
“Не могу загрузить указанный URL: 35 error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure”

How can I fix it?

Info about installation:
tt-rss git (93af11cb7a0b85766186df4f58682b51cb7d8315)
gentoo
mariadb 10.0.30 ~ mysql 5.6
php 5.6

tt-rss error reports: there is no new messages in log while I reproduce bug


#2

Old problem. Answered before here and here. :wink:


#3

I found this topics before, but I do not see solution in it.
I have openssl-1.0.2k


#4

I have 1.0.1t. No issues.


#5

Glad for you ))

So 1.0.2k is wrong version? There is no other 1.* version in Gentoo repos =(


#6

in case you are wondering why you don’t get help, maybe you should provide some more information about your setup like in the official support section?


#7

ok… sorry for inattention… I added info to first post


#8

And because this is very clearly an OS-level issue completely unrelated to TT-RSS.

Also, what @conrad784 said about curl right below this post.


#9

what happens, if you log into your server and call
curl "your wanted rss-feed link here"

if you got a valid openssl installation this should give you the feed in plain text


#10

looks like I have valid xml


#11

Do you have the PHP curl module installed and enabled?


#12

I know it… I didnot write about bug, I just asked to help ))


#13

Looks like this… but I’m not sure…
There is “Configure Command => … ‘–with-curl=/usr’” in output of “php -i”

I’ll try check it…


#14

php -m
should show you enabled modules


#15

Yes, it is there


#16

So there’s a disconnect between what’s supported in the command line with what PHP has available.

Can you post a larger excerpt of your PHP info? Specifically, there should be some information about OpenSSL, etc.

Also, even though curl shows up make sure it shows enabled for it (and for OpenSSL).

See the phpinfo() screenshot at the end of this article for an idea of what type of information to post here.

How are you running your update tasks? Cron, daemon, screen, etc.?


#17

is it enough? also I checked all my feeds in tt-rss and there is other https-feeds and they works fine


#18

Thanks, that helps. And how are you running your update tasks?


#19

Do you talk about this?
define(‘SIMPLE_UPDATE_MODE’, true);


#20

Ahh… Is that representative of how your feeds are updated?

e: If so, we need to re-run some stuff. Sometimes the command line operates different than the web interface. So we need to run phpinfo(); through the web browser to see if the settings are the same.

  1. Create a file at the document root (some random file name that you’ll remember (e.g. temp-32hf88.php), it’s just temporary). You can place this file inside the tt-rss directory to keep things simple.

  2. In it paste the contents below and save the file.:

    <?php phpinfo();

  3. Visit that page through your web browser and screenshot the appropriate sections for curl and OpenSSL.

  4. Delete the file you created.