[solved] Update problem for have a last version


Hi (sorry for ma bad english !)

I’m using kubuntu 14.04, php 7.0 and tt-rss without any problem. it’s works very well !!!

I would like upgrade my 16.8 version of tt-rss.

I go to my tt-rss folder and run commande line, but =>

mysuser@mycomputer:/var/www/tt-rss$ git pull origin master
fatal: Not a git repository (or any of the parent directories): .git

what’s the problem ?

thanks for your help and big thanks for your works !


The version you have in the tt-rss directory is not a git clone. You need to do an initial clone.

I’d recommend:

cd /var/www
mv tt-rss tt-rss-old
git clone https://git.tt-rss.org/git/tt-rss.git tt-rss
cp tt-rss-old/config.php tt-rss/config.php

If you use the cache_starred_images plugin, also do:

cp -pr tt-rss-old/cache/starred-images tt-rss/cache/

You’ll be up to date then, and future git pull commands will work.


if that’s something you installed via apt remove the package first, then do git clone.


Hi !

thanks for your answers :wink:

I would like know all changes for lastest version ?


git diff HEAD^ HEAD


See this thread:


Hi !

Solved !! it’s works :wink:

I don’t use ppa or deb but Git !! I donwload git clone copy in download folder. I don’t copy fine all folder after. “.git” isn’t copy in tt-rss folder !!!

after copy it, I can update tt-rss with comande line !!

big thanks for your help and works !!!