Tiny Tiny RSS: Community

[SOLVED] This feed URL goes in error (500)


#1

Hi,

I am running Tiny Tiny RSS v17.12 (bb0a8e3) on my personal server (Ubuntu Server 17.10, Apache2, PostgreSQL 9).

Basically this URL feed goes in error 500:
http://www.telefonino.net/rss_master.asp

The URL works from Firefox.

This is the output of the debug:

[08:26:18/494] start
[08:26:18/494] local cache will not be used for this feed
[08:26:18/494] last unconditional update request: 2017-12-31 16:02:02
[08:26:18/494] maximum allowed interval for conditional requests exceeded, forcing refetch
[08:26:18/494] fetching [http://www.telefonino.net/rss_master.asp] (force_refetch: 1)…
[08:26:18/494] fetch done.
[08:26:18/494] source last modified:
[08:26:18/494] unable to fetch: HTTP/1.1 500 Internal Server Error [500]

The same error in https://fakecake.org/myfeedsucks/.

Do you have an idea?

Many thanks,
g.


#2

an idea: consider reading the error output


#3

Hi fox,

thanks for the response.

I investigated and found that feed provider adds 500 error as response header, but the content is valid.
I print the headers returned in the “function fetch_file_contents” of the “include/functions.php” file:

HTTP/1.1 500 Internal Server Error
Cache-Control: private
Content-Length: 33637
Content-Type: text/xml
Expires: Tue, 02 Jan 2018 16:44:48 GMT
Server: Microsoft-IIS/7.0
Set-Cookie: ASPSESSIONIDQCRTBQDA=KCKMNOKBCCBAPDOLLAMGJLIK; path=/
X-Powered-By: ASP.NET
Date: Tue, 02 Jan 2018 16:29:47 GMT

Content-Length and Content-Type are valid, and payload is a regular XML.

I believe this is a very rare case, I don’t expect that tt-rss manages it. In the meanwhile I will arrange a workaround on my instance.

Many thanks,
g.


#4

there’s no facepalm big enough for this


#5

Ok, I found this trivial workaround.

Change line 149 of the “include/functions.php” to:

define(‘SELF_USER_AGENT’, ‘Wget/Tiny Tiny RSS/’ . VERSION . ’ (http://tt-rss.org/)’);

The “Wget/” in the user agent name makes it work.

g.


#6

It never ceases to amaze me how poorly web admins can run their sites. :man_facepalming: It’s amazing the internet works and even more so that as the human race we’re able to accomplish anything at all.

e: Is it just me or is Discourse showing a woman facepalming even though I picked
"man_facepalming"? How ironic…


#7

did you just gender that emoji :shocked:


#8

Even big companies like Oracle don’t get this right. Behold:

$ curl -H 'User-Agent: Tiny Tiny RSS/17.12 (4178dc8) (http://tt-rss.org/)' 'https://community.oracle.com/community/feeds/allcontent?community=13295'
File not found."
$ curl 'https://community.oracle.com/community/feeds/allcontent?community=13295'
File not found."
$ curl -H 'User-Agent: Tiny Tiny RSS/17.12 (4178dc8)' 'https://community.oracle.com/community/feeds/allcontent?community=13295'
<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:clearspace="http://www.jivesoftware.com/xmlns/jive/rss" version="2.0">
[...]

A URL in the User-Agent (or no User-Agent) breaks their feeds…

I sent them an email, but I doubt they’ll do anything about it. So I just set SELF_USER_AGENT in config.php.


#9

I know sites that ban tt-rss intentionally :frowning:


#10

Err… What seems rather strange.


#11

Some admins are idiots :wink: Somehow they think tt-rss is some kind of evil monster hammering their precious sites. Meh…


#12

Maybe they identify as male…