[SOLVED] SQL disk IO issues on tt-rss update on a Raspberry Pi


#21

Yes, quite a few, but as I mention above, they were running perfectly fine on Wheezy. I use Nagios for monitoring, and I rarely get too much load, except with things like Subsonic misbehave. TBH I was just considering moving everything off the SD onto USB, given how well mysql works now… but it’s so rare that I have problems that I’m not sure if I could be bothered.

Yes, I think that’s likely correct.


#22

I would suggest setting the ROW TYPE for ttrss_entries to COMPRESSED – it will take a while if you have a large table but as long as you are IOPS limited and not CPU limited you should see a performance gain. I run on Percona MySQL 5.7 with a bit over 1 million rows in that table and my setup is quite snappy – even if stuff isn’t in the buffer pool.


#23

Thanks for the suggestion. I’ll keep it in mind. However, because it’s a RPi, I’m not 100% sure where the CPU limit lies. That is, if I were to make it compressed, I’m not sure if I’d hit the CPU limit soon instead.