Tiny Tiny RSS: Community

[SOLVED] Issues with fetching feed (iptables?)


#1

Feeds from RSS-Bridge won’t get loaded and result in “Couldn’t download the specified URL: ; 28 Connection timed out after 15001 milliseconds”

If I do iptables -P INPUT ACCEPT on the machine I don’t get the error and it works without issues. But if INPUT is DROP than I get the error. ICMP is allowed and 443, 80 is opened. What checks are performed before validating the feed? It must be an iptables rule I am missing but I don’t know what because everything I think it needs is opened.
Note, RSS-Bridge and Tiny Tiny RSS are on the same host (behind NAT in a vm)

tt-rss version (including git commit id): latest master c7c9c5fb0ab6b3d4ea3078865670d6c1dfe2ecac

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions: Debian 9.7, postgres 11, PHP 7.0.33-0+deb9u1


#2

I got it solved. As this is behind NAT it was not enough to route 443 to public IP 443. I also needed to allow INPUT on host via 443 as the access to the RSS Bridge is done via the gateway.