Tiny Tiny RSS: Community

Recent PHP error when updating feeds


#1

Describe the problem you’re having:

Since February 17th I’m getting Uncaught: TypeError when updating feeds

If possible include steps to reproduce the problem:

tt-rss version (including git commit id):

Version v18.12 (9e7bbf6)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Arch Linux PHP 7.3.2 MySQL

Please provide any additional information below:

Strangely 1 feed is still updating sporadically. I rebooted the system after a kernel update yesterday which refreshed my feeds and I got about 25 news stories, but now it’s not refreshing properly. I use cron to update the feeds, but I also tried the update_daemon2.php file and get the same result.
CLI errors:
PHP Fatal error: Uncaught TypeError: Argument 1 passed to iterator_to_array() must implement interface Traversable, null given in /tt-rss/vendor/andreskrey/Readability/Nodes/NodeTrait.php:324
Stack trace:
#0 /tt-rss/vendor/andreskrey/Readability/Nodes/NodeTrait.php(324): iterator_to_array(NULL)
#1 /tt-rss/vendor/andreskrey/Readability/Nodes/NodeTrait.php(421): andreskrey\Readability\Nodes\DOM\DOMText->getChildren(true)
#2 /tt-rss/vendor/andreskrey/Readability/Readability.php(1272): andreskrey\Readability\Nodes\DOM\DOMText->hasSingleTagInsideElement(‘td’)
#3 /tt-rss/vendor/andreskrey/Readability/Readability.php(1166): andreskrey\Readability\Readability->prepArticle(Object(andreskrey\Readability\Nodes\DOM\DOMDocument))
#4 /tt-rss/vendor/andreskrey/Readability/Readability.php(155): andreskrey\Readability\Readability->rateNodes(Array)
#5 /tt-rss/vendor/andreskrey/Readability/Nodes/NodeTrait.php on line 324


split this topic #2

A post was merged into an existing topic: Issue since Readability update


closed #3