Tiny Tiny RSS: Community

Impending doom part 2: Objects


#1

Heads up: substantial javascript changes are going to be merged into master soon, those are currently staging in js-objects branch on gogs:

As usual, report all issues itt. If you want to play around with things and maybe find bugs before this pile of, uh, code hits master, check the branch out.


#2

Heads up, master merge of js-objects is imminent. Report all issues ITT.

image

here we go.gif


#3

Now at commit 3318555
Re: my complaint in thread… (Combined (unexpanded) mode has to go)

.

Again, with ‘Combined feed display’ ticked in Preferences. Now right-clicking…, then clicking ‘Open Original Article’ in the context menu does in fact mark the article read and then open the article at the linked website in a new browser tab as expected. … But. … The right-clicked article contents back in the tt-rss pane ALSO is opened. Not expected.

FWIW, disabling ‘Combined feed display’ in Preferences does yield the expected behavior of right-click…, Open Original… which opens the article in a new tab and marks the article in tt-rss read without expanding the article’s contents in tt-rss. Expected behavior.

Can this be fixed to get the same expected behavior when ‘Combined feed display’ is enabled?

.


#4

i think this should make it work as expected:


#5

Yup, that fix this issue (now at commit 9672ddf). Thanks very much @fox !
.


#6

Now at commit c700345

The issue:
Right-click on any article in any feed, click on ‘Toggle unread’ in context menu to mark the article unread or read depending on the article’s present state. At the bottom of the browser a ‘Loading, please wait’ bar appears and does not disappear as expected although the article has already been successfully marked unread / read.

The ‘Loading, please wait…’ bar remains visible until one clicks some where else in tt-rss. This also happens using keyboard shortcuts to select article, then mark read/unread.

Right-clicking on a feed in the Categories pane, click ‘Mark as read’ and the ‘Loading, please wait…’ bar appears momentarily and then goes away as expected.

Is no one else seeing this behavior?

.


#7

the underlying change here is that progress notifications don’t auto-hide anymore which is why a few got stuck like this (since they are not closed when the operation is complete)

i’m going to remove this particular loading… prompt but if you find any more please also report them.