Tiny Tiny RSS: Community

Few issues after recent updates


#1

Hi,
Describe the problem you’re having:

  1. I can’t see plugin list in preferences. If I create a new profile, plugin list is displayed correctly. I assume something might be wrong with my profile as my tt-rss instance is pretty old and I used a lot of outdated plugins. I’ve removed them but still no luck :frowning: Perhaps some old plugin setting is causing troubles? Logs are empty.

  2. Some feed icons have high resolution and look strange on the view:


  3. I have php 7.3 configured on my server. tt-rss logs are flooded with following errors:
    PHP Warning: “continue” targeting switch is equivalent to “break”. Did you mean to use “continue 2”? in /var/www/tt-rss/vendor/JShrink/Minifier.php on line 227". This is not a big deal as I switched to php 7.2 for tt-rss.

  4. After removing phpmailer I cannot send e-mails from tt-rss via my local mail server because I use postfix + dovecot as LDA and unfortunately dovecot do not support SMTPUTF8. Perhaps mailer could encode To: address not in utf-8? This is definitely my config issue, however perhaps mailer could be more compatible with older mailserver configs?

tt-rss version (including git commit id):
Tiny Tiny RSS v18.12 (c700345)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Debian (testing), PHP 7.2, PostgreSQL 11, Nginx

Regards


#2
  1. that’s interesting. does this commit help? you might need to login again:

E: also, there was a typo which prevented plugins list from rendering if there was for example mail plugin active, d’oh.

  1. hmm, i remember fixing this yesterday. you sure it’s not cached older css? that class should be covered by the following (right click on feed icon):

image

  1. that probably should be reported to JShrink developers. i’m not sure that we really need it anyway, maybe it’s time to finally drop it altogether.

  2. https://git.tt-rss.org/fox/ttrss-mailer-smtp

e: or are you already using the SMTP plugin? if you do and I misread you, check if phpmailer has a relevant option and if it does, i’ll add a configurable knob to the plugin.


#3
  1. Solved.
  2. I’ve restarted php7.2-fpm and it seems that icon size is fixed. Interesting that yesterday I restarted php and I wonder why it didn’t help.
  3. No problem.
  4. I do not need SMTP as my mailserver is on the same machine as tt-rss so php mail uses I believe sendmail or something like that. Anyway I’ll tinker a bit with php settings - this is a good suggestion, thanks!

#4
  1. that is entirely in CSS, so was a cache issue of some kind.
  2. oh i dunno then, PHP native mail() just works for me with postfix without any troubles. sendmail is usually a compatible wrapper provided by an actual MTA.

btw normally you don’t need to restart fpm daemon, uh, ever. why do that?


#5

Regarding mail - my mailserver uses dovecot as LDA so postfix sends the mail to local folder. Unfortunately dovecot does not support yet mails with UTF8 that’s why I’m getting errors. I think currently PHP sends mail in UTF8. I’ll investigate it and come back with my findings.

About fpm daemon - I recall setting some cache options in php.ini so I guess this is why I need from time to time to reboot it.

I believe this is the option:
opcache.validate_timestamps boolean

If enabled, OPcache will check for updated scripts every opcache.revalidate_freq seconds. When this directive is disabled, you must reset OPcache manually via opcache_reset(), opcache_invalidate() or by restarting the Web server for changes to the filesystem to take effect.

BTW I tried to change my css inline but it seems not working. Is this feature still supported? This is my snippet:

.cdm.expandable.active.Unread {
        background : white;
}
.cdm.expandable.active {
        background : whitesmoke;
}

#6

user css should work, maybe your style is not specific enough and gets overridden by stock stylesheet
you can check with element inspector in chrome

either that or add ! important to your overrides


#7

Yes !important did the trick! Thanks.


#8

Off-topic a bit: I used to set stuff up like that but I ended up finding it was annoying to restart the service after every update. The slow part is compiling the PHP files to bytecode. The setting above just determines if OpCache stats a file, which is a very fast operation. Unless your server is under a pretty constant and high load, you’ll probably notice no difference by changing it and you’ll benefit from not having to restart the service after every update.


#9

yeah in all honesty it is perplexing why would one have this enabled
unless it’s some super-duper loaded server where every extra stat() on a file really means something


#10

Regarding PHP config - it’s a legacy change that I used for another PHP app. It had a lot of optimizations checks and always complained about that feature (a big “Warning” bar on top of the page). So I just flipped the switch :slight_smile:

Anyway @fox do you know if this issue can be fixed? I mean those huge icons and emoticons - I’m observing this on several feeds for a long time :frowning:


#11

at first i thought it was an img srcset issue or something, but no, discourse emoticons are simply huge. you don’t see it on the forum because they are resized to 20px via css.

other than user css i’m not sure what could be done about it. there’s no way for tt-rss to know that this particular image should be small.

<img src="https://discourse.tt-rss.org/images/emoji/google_classic/slight_smile.png?v=6" title=":slight_smile:" class="emoji" alt=":slight_smile:">

they could’ve at least set width or something when exporting to rss.

e:

img[src*='discourse.tt-rss.org/images/emoji'] {
  weight : 20px;
  width : 20px;
  vertical-align : middle; 
}

#12

You could try reporting it as a bug :smiling_imp:[1]


[1] I got our forum banned for the last bug I reported.