Fever Plugin Broken on 14 Dec 2017?


#42

If you get time to try and chuck some echo statements in there and see if you get any output…that would be appreciated.

But yeah, your full nginx config seems to work fine for me too (after I changed some paths and generated a self-signed cert).

I don’t suppose your postgres instance is chucking out errors for invalid queries? Mine seems to pump them to syslog by default.


#43

OK. I’ve worked it out. I apologise and I’m very grateful for all of the time that you’ve given into looking at this for me. But it seems that if I had taken a look into the actual script I would have found the problem immediately. I was just editing it to add some debugging and the first thing I see is this on line 10 of index.php:

error_reporting(E_ERROR | E_PARSE);

Guess what? If I change that to E_ALL then it outputs the error!

2018/01/22 14:31:05 [error] 17546#0: *7762 FastCGI sent in stderr: "PHP message: PHP Warning: require_once(…/…/config.php): failed to open stream: No such file or directory in /usr/home/matt/www/ttrss/plugins.local/repos/fever/fever/index.php on line 12

So the actual root cause is how I install plugins.

in ttrss/plugins.local I have a repos directory. Inside that I git clone the fever repo. I then symlink ttrss/plugins.local/fever to ttrss/plugins.local/repos/fever/fever.

This means that when it’s looking for config.php it’s looking in the wrong directory as you are doing require_once “…/…/config.php”;

The previous code didn’t hardcode it like this. It used $tt_root = dirname(dirname(dirname($_SERVER[‘SCRIPT_FILENAME’])));

So at least now I know the problem and how to fix it.


#44

i have no words /20char


#45

Yes. Feel free to throw bear pictures at me :slight_smile:

The idea is that I just wanted to keep the repo up to date with git pull and not have to manually copy files around. As the repository doesn’t have the init.php, index.php, fever_api.php files in the root of the repository. The other option would have been to clone it and copy those files wouldn’t it? Or is there something in git that I’m missing where you can clone subdirectories.


#46

you can always clone someplace else and symlink the directory

e: oh wait, that’s exactly what you did. nvm.


#47

Yeah, I don’t know why someone changed the original directory structure. I will change it back.

I should have remembered about the error_reporting line…but that is mostly copied from tt-rss’s api/index.php

I will see about that obscure path checking for config.php also.


#48

OK,

I have pushed all my changes to master. https://github.com/DigitalDJ/tinytinyrss-fever-plugin

This should hopefully fix that issue and the PHP5 unserialize issue.


#49

Confirmed. I’ve tried the latest version and that now works fine with my obscure setup. Thank you very much for your help!


#50

Still getting an error as I try to set the Fever API password; using the Bitnami AWS AMI (and concerned about breaking it, should I just pull down the current git).


#51

I pulled down the current git, still getting the following:

The errors represent, from bottom to top, at attempt to set the fever-api user password followed by an attempt to login from Reeder.


#52

When was the last time you updated TT-RSS?


#53

This looks like an old version of tt-rss. Are you sure you have the latest git revision of tt-rss?