Feed updates starting but feeds not updating


Describe the problem you’re having:
In a system running for a good 200 days I’m now seeing a number of feeds in the database with “last_update_started” within the last 30 minutes (all feeds that should update every 30 minutes has as far as I can see). However the “last updated” field indicates no updates on a growing number of feeds (starting now to be around 24h since last_updated). If I go via admin and double click such a feed it updates and add a number of missing entries.

Whats the suggest process to either debug this and or simply get things to likely work as normal again?

tt-rss version (including git commit id):
Tiny Tiny RSS v16.8 (557d86f)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
‪Ubuntu 14.04.5 LTS‬


you can try feed debugger via f D, alternatively login via ssh, run update.php --debug-feed ID


Hmm, running the debugger on a feed that is no longer updating via the daemon resulted in the same as double clicking it; it finds updates, inserts missing entries and then also updates “last_updated” field in the DB. The same the daemon has done for 200 days flawlessly as well, though for some reason does not the last 24h on a high number of feeds.

Is killing and restarting the daemon likely to resolve if so I can try that next?


it wouldn’t hurt but if last_update_started is updated in the DB the daemon master is working properly


That’s a good point, technically it’s doing the job it is supposed to I guess. Not sure if the cache/lock files be corrupt or there be something else server wise, though no changes were done yesterday at least. I do have an expired SSL certificate I am due to update shortly (but that’s been expired for a week so again I’d presume it can’t be related).


Okay I’m going mad clearly - since I started to look into this about 60 minutes ago I now have zero feeds with not a last_updated date older than 35 minutes (except disabled and feeds with non-default intervals).

All I did was double clicking one feed to see if it updated, ran the debugger (but that was a while later) and clicked around in the preferences and well, can’t say I did anything that should have unclogged anything, but well, it works now and must have worked for a little while since it managed to catch-up with all feeds).


maybe restarting the daemon helped?

it’s too late now but if this happens one more time you can try looking at daemon console output (if you’re using systemd it’s very easy with journalctl)