Change on Tumblr: RSS feeds not working


#81

I do have: a really polite reply. Something like “uh, we appreciate your remarks, I forwarded them to our team” followed with a satisfaction form, etc. etc.
I think such a minor update could take some weeks, time for the ticket to enter into a sprint, studied by lawyers afraid by ugly European citizens, and so on…


#82

Optimist. They’ve known about GDPR for 2 years.

That said, they probably did nothing for most of it, panicked at the last minute, and shoved it out in 2 days hours


#83

Great, working for me again. Lets see what Tumblr will do next…


#84

Yeah but GDPR was finalised in January 2018 so nothing they did beforehand was actually useful. Still, tumbler has shown some Yahoo! level cluelessness here.


#85

Thank you for your help. Iinstall curl but doesn’t install curl module for php. Now all work fine.


#86

I just pulled and it works now, I assume that I was affected by the bug fixed with this commit.

edit: fixed link


#87

So many bugs for a so short plugin code.
But I’ve fixed a critical bug (prohibit new subs) about subscription to new feeds in the v1.2 version.


#88

:slight_smile: Welcome to life as a developer!

In any case, I and many here, are very grateful for your work. Thank you!


#89

I’m not sure if this is related to @GregThib’s plugin or tt-rss, but I can’t seem to enable the plugin. I tried putting it in plugins.local (tried plugins as well), changed permissions and ownership to match the other files and directories.
Any pointers to what I should check?


#90

Per Issue 5, can you confirm that you put it in a directory named tumblr_gdpr? The plugin won’t work if you give the directory a different name.


#91

Are you up-to-date with tt-rss ?
Maybe you have some debug information into “System” tab (into tt-rss preferences)


#92

This email from Tumblr:

Hello,

I wanted to give you a quick status update on the issue you reported. Our engineers are actively working on this bug, but it’s going to take some more time to fully resolve. Thank you for your patience!

Kind regards,
Seth

Not clear whether or not it’s a bot…


#93

Translation: we are clueless and have no idea what we are doing.


#94

i can just imagine the titanic effort involved


#95

I got exactly the same message, so bot it is…


#96

I don’t know if a plugin can handle that, but you just have to change the user-agent to googlebot to bypass the GDPR complain and to allow displaying feeds of tumblr blogs with “sensitive media” as well. No need to bake cookies anymore.


#97

you can definitely do that with a plugin, override fetch and set user-agent for CURL request for example


#98

@GregThib @Logological Thank you for your replies. I have been away for a week, but just confirmed that the problem was that I named the folder tumblr-gdpr and not tumblr_gpdr. The plugin seems to work for me now.


#99

Oh wow! I did not test that. It would have been much simpler.