Change on Tumblr: RSS feeds not working


#61

Screenshot%20from%202018-05-25%2013-38-59

Sorry, but they can’t even keep their own website up, so their reliability seems suspect.


#62

https://downforeveryoneorjustme.com/fastvps.ru :thinking:

not that this was an endorsement anyway

e: i’m using their Estonia-based offering for similar enough reasons.


#63

@Arvedui Installed your plugin and activated it in ttrss settings but all my Tumblr feeds are still broken ! Am I supposed to do something specific or will it fix all tumblr feeds at next cron refresh in TT ?


#64

Unfortunately my plugin broke due to the changes made by tumblr two days ago. I won’t fix it because I want do avoid duplicate effort.

I would gladly help @GregThib fixing his though, if he needs any.


#65

Thanks, will wait then that @GregThib found how to fix his plugin :wink:


#66

For what it’s worth, my hacky workaround using cookies still works, and it’s free:
link

It’s not as seamless and easy and safe, but it works…?


#67

I tried to use @GregThib 's plugin as well. Didn’t work (as expected). I tried to dig through the tumblr privacy consent site. But they really did a good job in obfuscating stuff.

Was somebody able to manually agree to the privacy settings using curl? I mean, recently, after they changed the site again (this change broke the existing plugins)?


#68

I sent a pull request which makes the plugin work again:


#69

Hey, Hi everybody.
Come back from a long week-end, I’ll take a look at @pdewacht PR soon, and modify to reflect changes.
Thank a lot @pdewacht for your effort. Great community work.


#70

Hi!

Merged fix from @pdewacht. Work again ! Enjoy.


#71

inb4 they put recaptcha there


#72

Estonia is in the EU so it must also abide by the GDPR.


#73

yeah i’m not using it because of GDPR, wink wink, etc


#74

Hi, Greg,
I install last version of plugin on last version of tt-rss (v17.12 (6361643)) and nothing work. For example this feed http://lewd-zko.tumblr.com/rss. If I try to manual fetch feed with debug I get a lot parsing errors. Is this problem with my tt-rss installation?


#75

Does not work for me either, I have no idea what the problem is tough.


#76

All of you experiencing trouble: you are also contacting tumblr, right? Because nothing short of user complaints will motivate change on their end, which would be the real fix.


#77

FWIW the updated plugin works for me just fine. Thanks for stepping up guys.


#78

With the last version of plugin, you should see debuging from it with the debug option of the daemon.
Example :

4) 00:27:19 $ /**obf**/php56 /**obf**/web/tt-rss/update.php --debug-feed 39
[22:27:39/11466] Lock: update.lock
[22:27:39/11466] start
[22:27:39/11466] Tumblr_GDPR: start
[22:27:39/11466] Tumblr_GDPR: form_key=!1231527546459|0MV9mqvChpDeUqstlbd2sSld64o
[22:27:41/11466] Tumblr_GDPR: cookie=pfg=6b0c3a866657c4edde24015232fdd1...; expires=Tue, 28 May-2019 22:27:41 GMT; Max-Age=31536000; path=/; domain=.tumblr.com; HttpOnly
[22:27:41/11466] Tumblr_GDPR: http_code=200
[22:27:41/11466] local cache will not be used for this feed
[22:27:41/11466] language: english
[22:27:41/11466] processing feed data...
[22:27:41/11466] site_url: http://lizclimo.tumblr.com/
[22:27:41/11466] feed_title: Hi, I m Liz
[22:27:41/11466] loading filters & labels...
Array
(
)
[22:27:41/11466] 0 filters loaded.
[22:27:41/11466] processing articles...
[22:27:41/11466] guid 2,http://lizclimo.tumblr.com/post/174250486929 / SHA1:ebd73ba0b135486f509d18327d98388a6fd51f42

Could you copy & paste your debug information ?

To be sure, have you :

  • installed the plugin into plugins.local/tumblr_gdpr/init.php ?
  • activated it in prefs or in config.php ?
  • optionally added some domains (not in .tumblr.com form) in new pane prefs ?
  • EDIT: are you sure to have curl (>= 7.10) installed and used by you php enviro ?

#79

Same thing: can you copy’n’paste debugging information from daemon ?
(last plugin version needed)


#80

The update works for me.

I’ve submitted a support ticket with tumblr, will report back if I get a sensible answer.

G.