Tiny Tiny RSS: Community

Can't update the feeds


PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

Describe the problem you’re having:

When fetch the feed in crond mode, it gets error, and can’t update the feeds.

If possible include steps to reproduce the problem:

just run the cron job as usual.

tt-rss version (including git commit id):


Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

CentOS 6.9,
php 5.5.38,
mysql Ver 14.14 Distrib 5.5.56, for Linux (x86_64) using readline 5.1

Please provide any additional information below:

in mail message:

Date: Mon, 13 Aug 2018 16:53:02 +0800

> PHP Fatal error: Cannot use object of type DOMNodeList as array in /home/wwwroot/default/tt-rssd/classes/feeditem/rss.php on line 199


Same issue here…

Ubuntu 14.04
PHP 5.5.9

E_ERROR (1) classes/feeditem/rss.php:199 Cannot use object of type DOMNodeList as array

Version up-to-date (fetched a few seconds)

EDIT: Last thing I did yesterday before the issue appeared was updating the Letsencrypt SSL via certbot. Not sure whether this is connected.


this seems to be supported since php 5.6.3[1] (released november 2014) so i suppose thus ends (unofficial) support of php 5.5 by tt-rss

  1. https://stackoverflow.com/a/39030256


I’m having the same issue as above.

Red Hat 4.8.2-15
PHP: 7.0.25
PGSQL: 8.4.20


that’s not something that actually exists, i’m afraid

going by this (released 2014) i find it hard to believe that you’re actually running tt-rss with php 7.0.25 (released 2017)

i’m not even going to mention that php 7.0 has no issues with above code

by the way, that postgresql version is not supported either.


I updated php 5 -> php 7 and things started to work again.
Still funny that it seems hitting people just now.

You might want to add mcrypt to the requirements page.
Thanks for the speedy information about the cause of the issue…


mcrypt is a) no longer a thing b) not required by tt-rss


tt-rss would not want to start unless apt-get install php7.0-mcrypt (and complained about missing mcrypt)
However this might be connected to Ubuntu 14.04 and PHP 7…?


oh boy, you have FEED_CRYPT_KEY defined in config.php. might want to look that one up.



I just upgrade 5.5.38 to 5.6.37, turn to be OK now.


Not sure what to say but when I did cat /proc/version it did show that version of Red Hat.

If php 7.0 does not have this issue is it the version of PGSQL that is causing the issue?


that’s not how you get an RHEL release name / version.

no, it’s not possible, although you can run into other issues.

what’s more likely is that you either don’t have php 7.0 or have multiple php versions installed. or you have a different problem.


Is there a way to rollback last nights changes? I’d like to do this until I can look into this some more and get on a supported version of PGSQL.



yes, just pick an older changeset id in git log and use git checkout. for example git checkout c3d57017d

when you’re ready use git checkout master to go back on trunk


Bugger. I’ve been bitten as well.

$ ttrss-bug-report

tt-rss version (including git commit id):

# git rev-parse --verify HEAD

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

# cat /etc/issue
CentOS release 6.9 (Final)
Kernel \r on an \m# uname -a
Linux server.onlinehome-server.info 2.6.32-042stab127.2 #1 SMP Thu Jan 4 16:41:44 MSK 2018 x86_64 x86_64 x86_64 GNU/Linux

# php --version
PHP 5.5.38 (cli) (built: Mar  1 2018 11:12:35) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies

# mysql --version
mysql  Ver 14.14 Distrib 5.5.60, for Linux (x86_64) using readline 5.1

Off to see about updating PHP I suppose…

Edit: Upgraded php to 5.6 - I’m sorted.

PHP 5.x, 7.0 support ending December 31, 2018!
Prevent running out of disk space with MySQL

holy shit, php 5.5 point releases lasted well into 2016. php may be an arguably shitty language but they do support their stuff.


this needs to be a thing


I seem to have really screwed the pooch now. Now when I try and refresh TT-RSS I get the below error. Odd that I did not see this before the update last night.

PHP version 5.6.0 or newer required.

I’ll have work on this later.


yes, latest update to tt-rss finally enforces required php version. looks like you actually don’t have php 7.0 (or you’re not really using it).

$ cat /usr/local/bin/ttrss-bug-report 



function run(){
        echo "# [email protected]"
        [email protected] | anonymise

echo -e "${GREEN}"

cat << EOF

# tt-rss version (including git commit id):

$( run git rev-parse --verify HEAD )

# Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
$( run cat /etc/issue )
$( run uname -a )

$( run php --version )

$( run mysql --version )


echo -e "${RESET}"

And (change where appropriate)

$ cat /usr/local/bin/anonymise 
sed -ue "s/my.site.name/mysite.example.com/g" | \
sed -ue "s/my.site.ip.address/<server ip address>/g" | \
sed -ue "s/my.home.ip.address/<my ip address>/g" | \
sed -ue "s/my.work.ip.address/<my ip address>/g" | \
sed -ue "s/hostname/server/g" 

Run and copy/paste.


not bad, although i’m not sure how distro-agnostic this is. also, no postgres version. :slight_smile:

e: we’re hijacking the thread tho