Tiny Tiny RSS: Community

Can't add feed, msg : Specified url could not be downloaded : false


#1

PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

*** Describe the problem you’re having:

When I try to add a feed, I have this error message :

L’URL spécifiée n’a pas pu être téléchargée : false

Which means : Specified url could not be downloaded : false

*** If possible include steps to reproduce the problem:

click action / subscribe to feed. In the url field, enter the url, choose a category (or not, doesn’t matter).
Also tried through the configuration panel, then feeds then subscribe to feed

*** tt-rss version (including git commit id):

updated to latest with “git pull origin master”, same result

*** Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Debian 8.1
PHP-fpm 7.2.2
Maria DB 10.1.33

Please provide any additional information below:

Error Log is empty
Tried the feed in https://fakecake.org/myfeedsucks/, feed looks ok
Tried an other rss feed, same result.
Tried an other browser (Vivaldi, no plugins), same result
I have many other feeds that were added before and are working good. update is ok.


#2

In the future, please put the actual commit (e.g. 32101389b6).

It would also be helpful to include the URL for the feed. However, when these things happen it’s best to try to fetch the feed from your server’s terminal (such as through SSH):

curl -iL http://example.com/feed/

You’ll probably find you’re getting some type of error related to either your server’s IP or the TT-RSS user agent.


#3

To be honest, i don"t know git very well.

I had this :

  • branch master -> FETCH_HEAD
    bcdbfa7…3210138 master -> origin/master
    Update bcdbfa7…3210138

So version is 3210138 ?

The url of the feed is http://rebble.io/feed.xml but I also tried the one from journaldugeek(dot)com with same result.

I had tried : curl -A “Tiny Tiny RSS/1.13 (tt-rss(dot)org/)” rebble(dot)io/feed.xml
With the same user as ttrss uses. I get the feed

Just tried with “curl -iL”, same result, I get the feed.

Also tried to add “define(‘NO_CURL’, 1);” in config.php but still same error message


#4

The commit version is listed at the bottom of the preferences screen along with the major version number.


#5

Thanks for the extra info.

I had no trouble accessing the feed. But I did notice it’s run through cloudflare, which is notorious for breaking this kind of thing—their anti-DOS screen is interactive and effectively blocks feeds because the feed reader doesn’t respond to the verification page. Though I suspect you’d get an actually http response code as the error if that were the case.

Just to be clear: when you successfully retrieved the feed using curl, did you try at that same moment in TT-RSS?


#6

Specified url could not be downloaded : false

i definitely remember this situation being discussed before but forum search doesn’t find anything relevant for some reason


#7

ok @darknite323 , thanks ! i’ll know for next time !


#8

Hi fox,
I found this : https://tt-rss.org/oldforum/viewtopic.php?f=1&t=3147&start=15
This is where I found about the
define(‘NO_CURL’, 1);


#9

Just to be clear: when you successfully retrieved the feed using curl, did you try at that same moment in TT-RSS?

I tried in the same minute or two but I can try again. Which curl parameters should I use ?


#10

I doubt it really matters. Lowercase i causes the response headers to be shown, capital L tells curl to follow redirects. Unfortunately, I don’t have other suggestions at this point.


#11

op, you can add the feed via bulk feed import in preferences -> feeds, then try using php ./update.php --debug-feed ID to check if its any different when running php from command line

also check that you have php7.0-curl package installed


#12

Hi @fox

phpinfo says :
cURL support enabled
Should be ok

I try with the bulk import but how do I know the ID of the stream ?


#13

Tried within the same 2 seconds. Works with curl -iL . Doesn’t with tt-rss :frowning:


#14

open the feed in tt-rss, look at the URL (#f=…)


#15

Could not do it right after adding it. But I noticed few hours later that I can seen the stream in my ttrss. So seems to work as far as I can tell.