Tiny Tiny RSS: Community

Can not log in my tt-rss site now


#1

When I update ttrss from commit 7d53c2b501cbc0e48f90c154b2f901fef08fbd33 to the latest one 5feed36a3cfab485dc56299b3c0e5721378453ea

I tried to login with username and password as usual, but the page fresh once, and I can’t login now.

add:
My browser is Chrome 69 on Mac OS 10.13.6.
Use IP address, no domain, no SSL. Looks like http://103.1.232.23/tt-rss
Use default admin as a login user


#2

Try clearing your cookies for the domain in question.

If that doesn’t work, try logging in using incognito or private browsing mode.


#3

yep start with deleting site cookies


#4

Just updated mine and am having the same issue. Deleting cookies, cleared cache, tried incognito, no luck so far. No error message received, just refreshes login page after clicking Login.


#5

try pressing login button one more time after it fails first

e: i think it also works if remember me is checked


#6

I clear all the cookies of Chrome 69, then tried, not working.

I also tried login using private browsing mode, not working.


#7

After the fail, all goes blank, press the login button, It needs me to fill with the username first.


#8

Still seeing the same as dudu. Second click on Login reloads the same page. Making some backups now and then I’m going to roll back the last pull.


#9

Ran “git reset --keep [email protected]{1}” and now I can login again.


#10

I’ll take a closer look a bit later


#11

alright, i’m taking a look and i’m not reproducing anything so far, both in firefox and chrome, blank profiles, seems to work fine.

affected people would have to provide more information, maybe SESSION_COOKIE_LIFETIME in config.php, whether you’re using SSL or not, any nonstandard auth_* plugins, http auth, etc.

so its specifically the 5feed36a3 commit that breaks things for you? are you on http?

e: not seeing any problems on plain http either.

e2: not seeing anything unusual on my mysql instance.


#12

define(‘SESSION_COOKIE_LIFETIME’, 86400);
define(‘SESSION_CHECK_ADDRESS’, 1);

SSL enabled via cert from Comodo

I’m a git newb so I’m not sure how to check the necessary history now that I rolled it back. After searching and trying a few things I’ve been able to view a list of what changed during the pull but not the commit id info.

Active plugins: af_zz_imgproxy, auth_internal, notes


#13

pull master (or checkout), git log, note top changeset, git reset --hard HEAD^, see if it starts working, note top changeset, repeat


#14

git pull origin master result, login problem returns:

commit 5feed36a3cfab485dc56299b3c0e5721378453ea (HEAD -> master, origin/master)
Author: Andrew Dolgov <[email protected]>
Date: Mon Oct 15 15:48:37 2018 +0300

git reset --keep [email protected]{1} result, login works:
commit f287596f0fe2a4f86bac7c784225ab0892b1d1c7 (HEAD -> master)
Author: Andrew Dolgov <[email protected]>
Date: Wed Oct 10 08:25:30 2018 +0300


#15

My browser is Chrome 69 on Mac OS 10.13.6.
Use IP address, no domain, no SSL. Looks like http://103.1.232.23/tt-rss
Use default admin as a login user

I have returned to commit 7d53c2b, it works.

and in my config.php : define(‘SESSION_COOKIE_LIFETIME’, 86400);

no any plugins.


#16

you went like 5 changesets down at once, this is not helping. you need to go one by one the way i’ve told you.

i’m interested in the last changeset before things break.

additionally, you two, post php version, i guess. also apache or nginx, etc.

also check tt-rss error log in preferences for anything of interest.


#17

After several “git pull” and “git reset --hard XXXX”, I found it breaks from the commit 65e98f40867862eb345676e23b633b9f52109d30.

php :
PHP 5.6.37 (cli) (built: Aug 13 2018 18:55:37) _
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
_ with Zend Guard Loader v3.3, Copyright © 1998-2014, by Zend Technologies

apache:
Server version: Apache/2.2.34 (Unix)
Server built: Jan 26 2018 14:01:59

mysql:
mysql Ver 14.14 Distrib 5.5.61, for Linux (x86_64) using readline 5.1

How to check tt-rss error log when I can’t login, or other place to find the error log?


#18

that’s a lot better

if you’re using default database logging you’ll have to roll back to the working changeset first and then check preferences.

e: also, try this: open F12 browser console and try to login, check for any cookie-related or other errors.


#19

So I git reset --hard to the latest working commit 74736fce0f89efbaa971e6817303e8840c4aed8f ,then I login, go to the preferences, but no error logs logged. _


#20

It’s too hard for me, I don’t know how to check any cookie-related errors…