Cached images are not cached anymore?


#1

Describe the problem you’re having:
Most of the feeds I subscribed to are set to “cache media” under the “Option” tab of the “Edit feed” menu.
Until few weeks ago images had the url of my tt-rss cache install. Yesterday I noticed they are not anymore (see attachment). I am not sure if a plugin is changing this behavior , but I did not activate/de-activate any as far I can remember. Moreover, images are saved in /cache/images

If possible include steps to reproduce the problem:
just change a feed with images to cache media and see the URL of the image.

tt-rss version (including git commit id):
17.4-532-g62d0060a

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
shared hosting, PHP 7.1.21, mysql Ver 15.1 Distrib 10.0.36-MariaDB

Please provide any additional information below:
see attachment
cached_images


#2

cache media rewrites source URLs for <img> and <video> elements only, i.e. embedded media content.

as you can see on your screenshot there’s no media rendered most likely because you’ve enabled low traffic option on the login screen, try disabling it.


#3

Has it always been like this?

I enabled low traffic to show that the url of the image was the original one, and not the rewritten.

I am quite sure once (maybe few weeks/months) ago the URL was rewritten also on low traffic mode, as this is how I use TT-RSS from my office. It did not (correctly) showed the images, but the URL (http://assets.amuniversal.com/373f46b0820801364d44005056a9545d in this case) was on my server, so that I could click it and still see the image (in a new Chrome tab).

Anyway, since TT-RSS has already downloaded the image in cache (as per feed’s setting), and has the URL of the cached image (that would be used in normal mode), why display the URL of the original image?

Hope I could explain myself.

Thank you in advance.


#4

as far as i remember, yes. at least that’s how it should have worked, it’s possible that some change fixed what i assumed was a bug.

there’s no image in your screenshot so it’s a bad example.

it’s done like that so you would still have access to original URL which is needed sometimes - for sharing or if something went wrong with downloading.

also, rewriting embedded media has privacy considerations because it auto plays, there’s no such concerns for a text link you need to actually click.

it would be very simple for a plugin to rewrite <a> elements too if their target is cached but i’d prefer to keep current behavior in stock. i can make a plugin like that if there’s a need and i have some time to kill.

e: i was bored so https://git.tt-rss.org/fox/ttrss-zz-textcached


#5

btw, regarding low bandwidth mode, i’ve just noticed that video/audio elements were not replaced with text links properly

per-feed global preference STRIP_IMAGES should now also affect other media elements


#6

I downloaded the plugin and it works beautifully. Thank you very much.

If I may disagree with you: I have access to the original URL through one click on the title of the post. I always thought that sharing was for the whole article, not a single image in a post (which may contain many images).
For example, in the android app, if I long tap an image and I choose to share, the url is the one of my domain, not the original one.

Anyway, thanks a lot for taking the time to accomodate my “original” workflow.


#7

maybe you’re right and everything should be rewritten, if nothing else it would be more consistent.


#8

I was not heading in that direction and I am sorry if you meant it like a critique.
Using the plugin is fine for me, and maybe if no one else noticed the difference (if there has ever been one, I am starting to doubt about my memory), it’s fine as it is now.

Again, thanks again for your support.

Regards


#9

Just curious if this is the same thing I started seeing August 30 where my GoComics feeds stopped displaying the images within my feed (see the difference between the two days); I haven’t made any changes to my settings, and quite honestly don’t remember when I updated before; I did git update yesterday afternoon and today’s comic (fetched overnight) is still missing; Just now updated again and added the Zz_Text_Cached plugin to see if it makes any difference.

Edit: my feeds did not have the option “Cache media” enabled before, but I have just now enabled it. I am using the af_zz_imageproxy plugin as well.


#10

For Pete’s sake. Nevermind, it’s working now. Sorry for the noise. sheesh