Tiny Tiny RSS: Community

Back to the logging page after some inactive time [FIXED: Error between keyboard and floor]


#1

Describe the problem you’re having:

I am generally leaving a tab (pinned) open with TTRSS on it. Generally, the page reloads every so often (when feeds update) and when I can be bothered looking at it, I can see new posts. All good so far.

In the last few weeks, sorry cannot remember which updates might have caused it, the page sometimes goes back to the logging screen. At first, I thought it was a weird passff interaction but disabling it has not affected that behaviour.

If possible include steps to reproduce the problem:

Leave a tab with TTRSS running in the background for a long (hour or a little more) period of time.

tt-rss version (including git commit id):

a130da2d1ab

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Ubuntu bionic 18.04
PHP 7.2.15-0ubuntu0.18.04.1
psql (PostgreSQL) 10.6 (Ubuntu 10.6-0ubuntu0.18.04.1)
Firefox 60.5.1esr (64-bit)

Please provide any additional information below:

Not sure if this is not a Firefox “feature”. Anyone else?


#2

well, did you try with a different browser?


#3

Trying as we speak. Had to install chromium… Oh the hardship⸮

Edit: Yep, it’s a firefox “feature”. FML.


#4

it’s likely something with your local settings or addons, firefox in stock configuration doesn’t just erase cookies for no reason


#5

And yet nothing there has changed in ages… Hum, I’ll keep looking into it and will update if I ever get to the bottom of it.


#6

I’ve seen something like this for a long time. Sometimes on Firefox, but mostly my iPad. Leave the page unattended for some length of time, and then come back to a login page.

It doesn’t happen to me often and I don’t have a repeatable test case. I’ve always assumed that what happened was a failed attempt to contact the server for updates. (Probably a timeout from my generally pretty good shared hosting.) I haven’t been logged out though, as I just hit refresh on the page and everything functions normally. No harm, no foul. Probably about the best thing I could expect ttrss to do in the circumstances.


#7

i guess it’s possible if SESSION_COOKIE_LIFETIME is zero or “remember me” is not checked when logging in

in this case its working as designed tho


#8

Since reloading the page works for me, there’s nothing wrong with the cookie.

I’m still going with the hunch that it’s error handling working as expected. Not enough of an issue for me that I’m going to bother tracking it down in the code though.

Thanks again for making something that works well enough on the iPad that I don’t have to bother trying to track down some app to read the news. Not to mention the entertainment from reading these forums.


#9

Fuck! I am a moron.

That new style icon had me confused. It need to be green, not unset as the tick is just there to be pretty.