After logging in for first time - Blank page


#1

Good morning

Describe the problem you’re having:

Today I have installed tt-rss for the first time ever. I followed the steps as given under https://git.tt-rss.org/git/tt-rss/wiki/InstallationNotes. Everything worked fine. The MySQL database was populated with tables. I copied the the config.php into the main directory.

When I opened the url to tt-rss (http://ttrss.aseiler.de/), the login screen appeared. I entered the default user name and password and clicked on “Anmelden” (Login).

A blank screen appeared.

If possible include steps to reproduce the problem:

… Check above mentioned link

tt-rss version (including git commit id):

…the most recent (cloned from git on 3.3.2018

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Linux (hosted at 1&1)
PHP 5.6
MySQL 5.5

Please provide any additional information below:

After searching google for possible solutions I did the following:

  • changed permissions for all files to 777 - didn’t change anything
  • checked the PHP log file - no entry

What else could I do?

Kind regards

intelligentinfo


#2

A blank page usually means a PHP fatal error. If you’re getting this after logging in (i.e. you can reach the login screen and submit the form) it probably means enough of TT-RSS is able to load that it can intercept the PHP errors; by default TT-RSS logs them to its database.

Try temporarily changing LOG_DESTINATION in the config.php file to an empty string (i.e. just two single quotes).

Then open your browser’s inspector and attempt to login. If it doesn’t work, report back the HTTP response code and check the PHP log files on the server for errors–report them as well.


#3

I am also getting this error, but only in firefox.

No php error. Javascript console is reporting the following

XML Parsing Error: no root element found
Location: https://host/cdn-cgi/pe/bag2?r[]=https%3A%2F%2Fhost%2Flib%2Fscriptaculous%2Fscriptaculous.js%3F1522112685%26load%3Deffects%2Ccontrols
Line Number 1, Column 1:
bag2:1:1
XML Parsing Error: no root element found
Location: https://host/cdn-cgi/pe/bag2?r[]=https%3A%2F%2Fhost%2Flib%2Fscriptaculous%2Feffects.js&r[]=https%3A%2F%2Fhost%2Flib%2Fscriptaculous%2Fcontrols.js
Line Number 1, Column 1:
bag2:1:1
XML Parsing Error: no root element found
Location: https://host/cdn-cgi/pe/bag2?r[]=https%3A%2F%2Fhost%2Flib%2Fdojo%2Fnls%2Ftt-rss-layer_en-us.js%3F1522114370594
Line Number 1, Column 1:

#4

your browser is probably infected
check addons etc


#5

Sorry, are you kidding? No my browser is not infected. Turns out it was an issue with Cloudflare rocket loader. Disabling that with a page rule fixed my issue. Odd that it was only happening on Firefox.


#6

a browser addon gone rogue could easily cause something like that
sorry i was not telepathic enough to recognize your cloudflare issue without any context

now since you decided to sass me for trying to help you, enjoy your probation

also in general if you decide to post here again please don’t hijack someone elses threads with your likely different issue