Access by local ip and domain


#1

Hi,

I’ve just pulled the latest tt-rss from git.

Now with this update, I can’t access my installation of tt-rss on the local network since it is configured to point out to a proper domain name (to access it remotely).

Startup failed

Tiny Tiny RSS was unable to start properly. This usually means a misconfiguration or an incomplete upgrade. Please fix errors indicated by the following messages:
Please set SELF_URL_PATH to the correct value detected for your server: https://192.168.0.10/tt-rss/

Is it possible to include in the future, a way to have again both the possibility to access tt-rss both locally and remotely.

I’ve noticed more “reactivity” when I browse it locally, but I still need to point out to the domain because I share some rss made by tt-rss with other people.

As I read in tt-rss/wiki/InstallationNotes :

Proceed with the installation using the easy installer. It will ask your database credentials and a full URL on which tt-rss will be accessed, for example http://your.site.com/tt-rss/install/. It is required that the URL is an externally accessible one (if any), don’t use localhost there, it will break PUSH support. If you are deploying tt-rss on LAN, you can disregard this requirement.

So maybe it’s not possible anymore…


#2

You might want to read this thread After today's upgrade (6.7.2017)
Especially this post might be interesting for your use case After today's upgrade (6.7.2017)


#3

just disable the check


#4

Thanks it works…
I didn’t put the right keyword in the search bar…


#5

Usually routers are smart enough to stay in the local network when using the externally accessible domain name on a local device. On ASUS routers it’s controlled by the NAT Loopback setting.